Forum Discussion

jonjac's avatar
New Contributor
2 years ago

How do I enable TLS 1.0 in SoapUI 5.7?

I am trying to send requests to an old system that uses TLS1.0. How do I enable it in SoapUI on macOS?



I tried adding ‑Djdk.tls.client.protocols="TLSv1,TLSv1.1,TLSv1.2" to JAVA_OPTS in in the application package directory Contents/java/app/bin/ but it didn't seem to help.


3 Replies

  • nmrao's avatar
    Champion Level 3

    jonjac you should use just the version required instead of all separated by comma.

    • jonjac's avatar
      New Contributor

      Don't really understad what you mean. I have added the protocol to this string to no avail:


      JAVA_OPTS="-Xms128m -Xmx1024m -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -Dgroovy.source.encoding=iso-8859-1 -Dsoapui.home=$SOAPUI_HOME/bin -splash:SoapUI-Spashscreen.png ‑Djdk.tls.client.protocols=TLSv1"


      also tried with -Dsoapui.https.protocols=TLSv1 which I saw in another discussion. But no difference what so ever.