Forum Discussion

deluycmi's avatar
deluycmi
New Contributor
6 years ago
Solved

SOAPUI returns <not-xml/> in Request and Response

Hello,

 

Last week, I got a new computer from work and had to migrate my data from my old one. I had to reinstall all my programs, including ReadyAPI. I imported the SOAP-projects from my old PC on to the new one. I encountered follow problem:

 

For some reason, whenever I execute a TestCase, both the Response and Request have a value of <not-xml/>. See screenshot attached.

 

I already viewed the forum and "Discard Succesful Results" under "Default Test Case Options" is unchecked in my Preferences.

 

Can anyone help me with this problem?

 

Thanks in advance.

 

 

 

  • Hello,

     

    With the help of the SmartBear support, I found a solution to my problem today.

     

    My TestCases are mostly request within a data-driven loop. In ReadyAPI Version 2.3.0, a new option was introduced to reduce the memory consumption during data-driven testing.

     

    In the configuration of the DataSource Loop, there is an option "Discard PASS Results with Loop".

    See following screenshot:

     

    This option needs to be unchecked, because it basically does the same thing as the "Discard Succesful Result" under the "Default Test Case Options" in the general Preferences.

     

    I hope this helps anyone who has a similar problem.

10 Replies

  • deluycmi's avatar
    deluycmi
    New Contributor

    Hello,

     

    With the help of the SmartBear support, I found a solution to my problem today.

     

    My TestCases are mostly request within a data-driven loop. In ReadyAPI Version 2.3.0, a new option was introduced to reduce the memory consumption during data-driven testing.

     

    In the configuration of the DataSource Loop, there is an option "Discard PASS Results with Loop".

    See following screenshot:

     

    This option needs to be unchecked, because it basically does the same thing as the "Discard Succesful Result" under the "Default Test Case Options" in the general Preferences.

     

    I hope this helps anyone who has a similar problem.

    • pallavimistry's avatar
      pallavimistry
      Regular Visitor

      Thanks, this was the exact issue I faced today and your solution helped a lot. Thanks again !

      • kellkevin's avatar
        kellkevin
        New Contributor

        I still have issues with xml request. It still appears as not-xml but I do have that option set off. Was there something I'm missing?

  • Nastya_Khovrina's avatar
    Nastya_Khovrina
    SmartBear Alumni (Retired)

    Hi deluycmi,

     

    Thank you for your post. The test history functionality may be disabled if the database schema is not compatible with the current version of ReadyAPI. Please see the screenshot:

    Please doulbe-click on the problematic test case or test suite and select Update.

     

     

  • deluycmi's avatar
    deluycmi
    New Contributor

    Hi Anastasia,

     

    Unfortunately, I do not have the ability to Update the test case or test suite to work with the latest version.

     

    The option simply is not available.

     

    Friendly regards,

    Mike