Forum Discussion

mpilone's avatar
New Contributor
12 years ago

SoapUI Freezes on OSX Mountain Lion (10.8.0)

I recently upgraded my machine to Mountain Lion and now SoapUI freezes at startup. It displays the main window but then within a few seconds it goes solid gray and the beach ball starts spinning. It sounds like the same problem as in this post:

but I'm not able to even get into the general preferences to modify the browser setting because the application freezes too quickly. It there some option I can put in my configuration file to try to disable the browser?

Note that this same install was working fine on this machine using Lion (10.7). Here is stdout when running from the terminal:

= SOAPUI_HOME = /Users/mpilone/Applications/soapui-4.5.1
Configuring log4j from [/Users/mpilone/Applications/soapui-4.5.1/bin/soapui-log4j.xml]
15:29:24,397 INFO [DefaultSoapUICore] initialized soapui-settings from [/Users/mpilone/Applications/soapui-4.5.1/soapui-settings.xml]
15:29:25,004 INFO [SoapUI] Used java version: 1.6.0_33
objc[18149]: Class MessageLoopView is implemented in both /private/var/folders/4x/9xk66kd13bg6lpz2n3qc2wwr0000gn/T/jxbrowser-3.0.Build.Unknown/libjniw.jnilib and /private/var/folders/4x/9xk66kd13bg6lpz2n3qc2wwr0000gn/T/jxbrowser-3.0.Build.Unknown/libjniwrap.jnilib. One of the two will be used. Which one is undefined.
objc[18149]: Class MessageLoopView is implemented in both /private/var/folders/4x/9xk66kd13bg6lpz2n3qc2wwr0000gn/T/jxbrowser-3.0.Build.Unknown/libjniw.jnilib and /var/folders/4x/9xk66kd13bg6lpz2n3qc2wwr0000gn/T/jxbrowser-3.0.Build.Unknown/libjniw.jnilib. One of the two will be used. Which one is undefined.
2012-08-13 15:29:26.598 java[18149:14203] [Java CocoaComponent compatibility mode]: Enabled
2012-08-13 15:29:26.619 java[18149:2707] java.lang.Exception: Object owner or JVM pointer are not correct
2012-08-13 15:29:26.620 java[18149:2707] (
0 CoreFoundation 0x00007fff8ba52716 __exceptionPreprocess + 198
1 libobjc.A.dylib 0x00007fff90061470 objc_exception_throw + 43
2 CoreFoundation 0x00007fff8bae6899 -[NSException raise] + 9
3 JavaNativeFoundation 0x0000000104771c3f JNFCallStaticVoidMethod + 213
4 libawt.jnilib 0x000000010e88d8b5 setBusy + 53
5 CoreFoundation 0x00007fff8ba190c7 __CFRUNLOOP_IS_CALLING_OUT_TO_AN_OBSERVER_CALLBACK_FUNCTION__ + 23
6 CoreFoundation 0x00007fff8ba19031 __CFRunLoopDoObservers + 369
7 CoreFoundation 0x00007fff8b9f4571 __CFRunLoopRun + 929
8 CoreFoundation 0x00007fff8b9f3dd2 CFRunLoopRunSpecific + 290
9 HIToolbox 0x00007fff8dbcb774 RunCurrentEventLoopInMode + 209
10 HIToolbox 0x00007fff8dbcb512 ReceiveNextEventCommon + 356
11 HIToolbox 0x00007fff8dbcb3a3 BlockUntilNextEventMatchingListInMode + 62
12 AppKit 0x00007fff8905efa3 _DPSNextEvent + 685
13 AppKit 0x00007fff8905e862 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
14 libawt.jnilib 0x000000010e88efe3 -[NSApplicationAWT nextEventMatchingMask:untilDate:inMode:dequeue:] + 124
15 AppKit 0x00007fff89055c03 -[NSApplication run] + 517
16 libawt.jnilib 0x000000010e88d694 +[AWTStarter startAWT:] + 1495
17 libawt.jnilib 0x000000010e88d00e -[CPerformer perform] + 93
18 Foundation 0x00007fff8b36a8a7 __NSThreadPerformPerform + 225
19 CoreFoundation 0x00007fff8b9d1841 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
20 CoreFoundation 0x00007fff8b9d1165 __CFRunLoopDoSources0 + 245
21 CoreFoundation 0x00007fff8b9f44e5 __CFRunLoopRun + 789
22 CoreFoundation 0x00007fff8b9f3dd2 CFRunLoopRunSpecific + 290
23 java 0x0000000103e90843 java + 18499
24 java 0x0000000103e9029a java + 17050
25 java 0x0000000103e8da98 java + 6808
26 ??? 0x000000000000000e 0x0 + 14

7 Replies

  • mpilone's avatar
    New Contributor
    Following the original SoapUI Pro thread indicated that disabling the integrated browser solves the problem. I couldn't get SoapUI to stay open long enough to do this through the Settings dialog so I edited the soapui-settings.xml directly. Adding this setting solved the problem:

    <con:setting id="UISettings@disable-browser">true</con:setting>

    It looks like the integrated browser causes the application to lockup on Mountain Lion.

  • Worked for me as well

    the soapui-settings.xml was on my home directory and the UISettings@disable-browser setting was pre-existing, just had to turn false to true
  • Hi everyone,
    The soapui-settings.xml never got created for me. So after sniffing around the internet looking for the right format... this is what solved it for me.

    On the Mac, make sure that you create the soapui-settings.xml in your home directory (like /Users/<username>/).
    Then create the file with the following content:

    <?xml version="1.0" encoding="UTF-8"?>
    <con:soapui-settings xmlns:con="">
    <con:setting id="UISettings@disable-browser">true</con:setting>

    Save the file, and then restart SoapUI 4.5.1 in mountain lion and you should not see the spinning wheel anymore!

  • Solved for me as well. As old as this issue is I was surprised at how difficult it was to find info. I tried several other methods to resolve hanging at start up like adding the jvm option but none of them worked.

    I had to create my soapui-settings.xml file as dennisjbr describes above, after that no hang, no beachball, seems to be running fine. If someone could post an entire settings.xml file here I would love to see what else is supposed to be in there.

    I wonder if there is a bug in the install? During installation I opted to install loadUI and at some point there was an access denied issue. I just pushed on but was left without the settings.xml file.

    Thanks for the help!
  • joensson's avatar
    New Contributor
    SoapUI 5.0 was extremely slow on my Mac OSx Mavericks - it literally took several minutes after starting the application before I could do anything in the UI. There was a blank (grey) window open in the large area in the ui to the right.

    After adding the <con:setting id="UISettings@disable-browser">true</con:setting> to ~/soapui-settings.xml and restarting SoapUI 5.0 it now starts up quickly and is responsive in the UI immediately. A much much better user experience. Thank you :-)

    I know several people in my company who have uninstalled SoapUI from their macs due to it not being responsive after starting up, this simple setting fixes their problems too.