Forum Discussion

ANRAPI's avatar
New Contributor
5 years ago

Openapi 3.0.1 in ReadyAPI 3.0.0

I'm working with ReadyAPI 3.0.0.

I want to add API from Swagger/OpenAPI Definition 5REST) with Jsonfile {"openapi":"3.0.1",...

It worked well in the previous version of swagger jsonfile {"swagger":"2.0",...


Has anyone a solution?

  • Thank you richie, nmrao!


    ANRAPI , were you able to solve this yet? If not, opening a support ticket might be a good idea. 



8 Replies

  • richie's avatar
    Community Hero
    Hi ANRAPI,

    You dont actually mention what the problem is! :)

    You ask about a solution and mention openapi v3.0, but whats actually happening?

    Whats actually the response when you try and load in the file?
    Are you sure that openAPI v3.0 is supported by ReadyAPI! V3.0?


    • ANRAPI's avatar
      New Contributor


      Recently we have updated the Json-files {"swagger":"2.0",...} to {"openapi":"3.0.1",...} It worked well with version 2.0.
      If I add the API with Json {"openapi":"3.0.1",...} the following type of errors is given:
      1/  attribute paths.'/api/v1/...'(post).swaggerIgnore is unexpected

      2/  attribute components.schemas.Support.Api.Controllers.OAuth.ClientCredentialGrant.ClientCredentialGrantWithAllScopesRequest.additionalProperties is not of type `object`
      3/ attribute components.schemas.Schema name Infrastructure.Api.Hydra.HydraCollection  doesn't adhere to regular expression ^[a-zA-Z0-9\.\-_]+$

      I'm not sure that openAPI v3.0 is supported by ReadyAPI V3.0