Forum Discussion

Udayadeepthi's avatar
Udayadeepthi
Occasional Contributor
3 years ago

Import graphql definition from apollographql

Hi, 

 

I'm new to graphql testing and trying to import the definition which i saved as .graphql but readyapi gives me error saying incorrect format. can you please let me know who do we import the graphql to readyapi api definition ? 

 

thanks,

Deepthi 

8 Replies

  • Hi Udayadeepthi ,

    have you only tried to import that single graphql file?

    I've  pasted a sample graphql schema. Can you put that in to a .graphql file and see if it imports correctly? If so, you can compare your schema against it and see if there are any major differences. That might be a good starting point

    schema {
      query: Query
    }
    
    type Tweet {
        id: ID!
        # The tweet text. No more than 140 characters!
        body: String
        # When the tweet was published
        date: Date
        # Who published the tweet
        Author: User
        # Views, retweets, likes, etc
        Stats: Stat
    }
    
    type User {
        id: ID!
        username: String
        first_name: String
        last_name: String
        full_name: String
        name: String @deprecated
        avatar_url: Url
    }
    
    type Stat {
        views: Int
        likes: Int
        retweets: Int
        responses: Int
    }
    
    type Notification {
        id: ID
        date: Date
        type: String
    }
    
    type Meta {
        count: Int
    }
    
    scalar Url
    scalar Date
    
    type Query {
        Tweet(id: ID!): Tweet
        Tweets(limit: Int, skip: Int, sort_field: String, sort_order: String): [Tweet]
        TweetsMeta: Meta
        User(id: ID!): User
        Notifications(limit: Int): [Notification]
        NotificationsMeta: Meta
    }
    
    type Mutation {
        createTweet (
            body: String
        ğŸ˜ž Tweet
        deleteTweet(id: ID!): Tweet
        markTweetRead(id: ID!): Boolean
    }

     

    • Udayadeepthi's avatar
      Udayadeepthi
      Occasional Contributor

      Can i get this format from Apollographql studio? 

    • Udayadeepthi's avatar
      Udayadeepthi
      Occasional Contributor

      I've tried this sample format it gives me error saying syntax error at deleteTweet and markTweetRead both places. 

      • MConneely's avatar
        MConneely
        Staff

        Udayadeepthi I cannot upload a .graphql file directly, but ive attached it as a text file so you could try downloading and coverting to a .graphql file.

        I've imported it on version 3.30.0. What ReadyAPI verison are you using? Have you a sample that you have been testing with that you want to share?