Forum Discussion

dvantveld's avatar
New Contributor
9 years ago

Upgrade JIRA Connector 11 to 12 is failing missing file qacJIRAConnector.Service.InstallState

We have the QAComplete JIRA Connector 11 (version installed and I'm trying to install (there does not appear to be an upgrade method other than to start the installation of the new version)...
  • dvantveld's avatar
    9 years ago

    After a bit more digging, we found that the reason for the upgrade failing originally is that the software is not actually able to do a proper upgrade. It removes the software, but can't deal with the running service. Even when you stop the service, it can't actually proceed. It should be stopping the service and uninstalling the service, but instead it presents a message saying that the service is already running and then rolls back the upgrade, removing the application (so also the old version), but leaves the service. So this then prevents any repair, removal or installation from that point onwards.


    We managed to fix it by doing an sc delete on the service, after which the installation worked fine. So, in conclusion, if anyone upgrades the connector, I recommend stopping the service, uninstalling the software, check that the service has been removed (and if not using the sc delete command via the command line) and then install the new version.


    I think I have retained our settings/configurations by copying the previous settings.xml file and the Data folder. It's looking ok at first glance but we'll need to verify in greater detail to make sure. In any case, problem solved.