Forum Discussion

Vinayak03's avatar
New Member
11 months ago

Cypress installation before I run npx visualtest-setup



I have issue installing cypress.


I tried installing cypress using this command.

npm install Anonymous/visualtest-cypress@latest

After I run this command,

npx visualtest-setup,  It still shows me cypress not found. 

If I try installing cypress with this command:  npm install cypress,  it gives me error: unable to get local issuer certificate.

Then later on, I also tried setting up SSL certification config false by using various command like:
1] git config --global http.sslcainfo /mingw64/ssl/certs/ca-bundle.crt
2] git config --global http.sslbackend schannel

3] git config --global http.sslVerify false

but still no luck.


Note: I am using my company laptop and it has some firewall or proxy settings and might be due to those settings it won't allow me to install cypress.

Please let me know if you have any better solution for me.

1 Reply

  • hi Vinayak03 

    Apologies for the late response as this is a new community;

    from the info you've provided, the SSL issue seems local to your environment. I've found some related documentation (  ) which may help debug the issue.


    we also recently released playwright-js support as well (although it is likely you may run into similar SSL issue when trying to npm install playwright as well, if you are facing such issues with cypress)


    Finally, we also recently released our 'manual' screenshots; users can input any public facing url, and get visual regressions by "running test" from various OS/browser configuration.