Forum Discussion

jeffgaer's avatar
Occasional Contributor
9 years ago

missing dependancies building soapUI from source on git

Some of the dependancies are not being resolved when I try to build the source downloaded from git using maven. I am tracking some of the down myself, but noticed that some appear to not be open source ( saxon ). Any help or guidance would be appreciated.


[ERROR] Failed to execute goal on project soapui: Could not resolve dependencies for project com.smartbear.soapui:soapui:jar:5.2.2-SNAPSHOT: The following artifacts could not be resolved: xmlbeans:xbean:jar:fixed-2.4.0, xmlbeans:xbean_xpath:jar:2.4.0, xmlbeans:xmlpublic:jar:2.4.0,,, jetty:jetty:jar:6.1.26, jetty:jetty-util:jar:6.1.26, jetty:servlet-api:jar:2.5-20081211, wsdl4j:wsdl4j:jar:1.6.2-fixed, commons-ssl:not-yet-commons-ssl:jar:0.3.11, json:json-lib:jar:2.2.2-jdk15, ezmorph:ezmorph:jar:1.0.5, swingx:swingx:jar:soapui, saxon:saxon:jar:, saxon:saxon-dom:jar:, bouncycastle:bcprov-jdk15:jar:144, jtidy:jtidy:jar:r872-jdk15, hermesjms:hermes:jar:1.14, amf:flex-messaging-common:jar:1.0, amf:flex-messaging-core:jar:1.0, amf:flex-messaging-opt:jar:1.0, amf:flex-messaging-proxy:jar:1.0, amf:flex-messaging-remoting:jar:1.0, thoughtworks:xstream:jar:1.3.1, l2fprod:l2fprod-common-directorychooser:jar:7.3, l2fprod:l2fprod-common-fontchooser:jar:7.3, org.apache.xerces:xml-apis:jar:2.9.1, gnu.cajo:cajo:jar:1.142, com.btr:proxy-vole:jar:20131209, org.sonatype.install4j:i4jruntime:jar:5.1.14: Could not find artifact xmlbeans:xbean:jar:fixed-2.4.0 in nexus-public (

2 Replies

  • Gabby's avatar
    Occasional Visitor

    I have met the same problem as yours. Have you fixed it, and then to share the solution?

    • jeffgaer's avatar
      Occasional Contributor

      I have not gotten a response nor have I worked it out.