Forum Discussion

HolyA's avatar
Occasional Contributor
7 years ago

"Add Assertion" Window Not Allowing to Add Assertions

Hello experts,


I am facing the same issue the user here outlines (from the Pro version, a couple years ago) :


In a nutshell, what is happening :


  1. I am able to properly create a new project/test suite/test case/test request and make successful calls, appropriately.
  2. When I create a new test request and come to add an assertion, first time after the install I get the submenu "Property Content" and although I am able to select any one of the items not greyed out, the "add" button stays greyed out (see attached screenshot).
  3. If I however double click a (not greyed out) item, such as "XPath Match", it does get added to assertions list and can operate normally on my test case and step.
  4. I am totally unable to select any other subemenu items under "Property Content", but the next time I reopen the "Add Assertion" window, I get the (expectedly) "Recently used" subemnu at the top, showing my last selected item, but I can't go to any of the other subemnu items beneath it.
  5. At that point, whenever I click on a new submenuu category, nothing happens, until I move the mouse cursor OFF of the cell of the submenu item, at which point it greys out. I can end up graying out several items this way, and they stay in grey until I mouse on and then off them again (see attached screenshots).


Troubleshooting steps taken :


  1. Tried with version 5.4.0 64 bits and 32 bits, as well as 5.2.1 64 bits.
  2. Between each uninstall/install, I did delete all folders, including in %localappdata% and at the root of my user directory (.soapuios, default-soapui-workspace.xml, soapui-settings.xml), and also rebooted.
  3. Nothing in the logs is helpful in troubleshooting this.
  4. Tried to launch as administrator.
  5. Tried to change the jre pointed from the one in the install folder to various ones I got installed (1.7.45 and 1.8.162).
  6. Removed all plugins from .soapuios


Lastly, I'll add that :


  1. I am an experienced user on SoapUI, have been using it to test my apis for a few years now and I've done tons of test suites and projects, including all sort of assertions.
  2. I'm now operating off of a new client's environment and thus had to reinstall my tools over his basic machine image. I do have admin rights on the machine. Other users in the same environment are able to operate these functions ok.
  3. The OS is Win7-x64 Pro running on Intel, all latest security patches installed.


See the logs, screenshots and sample project attached.


Any help would be great, even if to help me just get more info on what's going wrong so I can take it a step further with my local environment.


Thanks in advance!