Forum Discussion

pascal1's avatar
Frequent Visitor
2 years ago

[CPP] Error while building Repo


i tried to build the Cucumber-cpp Repo from Github. I tried the lastest Commit, but also the release 0.5 but none of them cant be build. When i run the ¨cmake --build build¨ command i get an error with GTest ¨LINK : fatal error LNK1104: cannot open file '..\gmock\src\gmock-build\lib\Debug\gmock_main.lib' [C:\Users\...\Docume
nts\Code\cucumber-cpp\build\tests\BasicStepTest.vcxproj]¨. The code tries to find a ¨Debug\gmock_main.lib¨ file, but when i look in the folder there is a ¨gmockd_main.lib¨ file. And this happens with all the files in this Debug folder. But even if i fix this gtest errors by hand, i get the next error that a file is missing ¨libboost_thread_vc143...¨, but boost 1.81 is installed.


So can you help me so that i can build this project or is this abondend? Because the last release is 5 years old.


Do i need to build the repo to use it in my private project? And how do i include cucumber-cpp in my project?




No RepliesBe the first to reply