Forum Discussion

jmcintyre's avatar
jmcintyre
Occasional Visitor
23 days ago

Perforce Setup

I'm attempting to setup Perforce source control integration as instructed here: https://support.smartbear.com/collaborator/docs/source-control/perforce.html

When I use the "Test Connection" button to test the connection to the Perforce server I receive a "must run p4 trust" error even though I've placed the p4 trust file at /etc/init.d/ as instructed in the documentation. The root user also has the same .p4trust file in their home directory. I've verified that the p4 command line application is correctly using the p4trust file to trust my server. What do I need to do to have the .p4trust file recognized in CodeCollaborator?

In case it's helpful the server is running Amazon Linux 2 (EC2) and installation was done using the standard install script and default installation options. I've attached images of the error and my .p4trust file in the instructed location.

 

No RepliesBe the first to reply