Ask a Question

testcomplete 12.50 not recording

rmnrdi
Contributor

testcomplete 12.50 not recording

Is anyone else having an issue with TC 12.50 only recording a fraction of what it's supposed to?

 

I tried recording a script and keyword test, but both are not recognizing 90% of what I did. 

8 REPLIES 8
Marsha_R
Community Hero

Re: testcomplete 12.50 not recording

What happens when you try?  Can you give us some specifics?

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
rmnrdi
Contributor

Re: testcomplete 12.50 not recording

It's not recording any keystrokes whatsoever

cunderw
Community Hero

Re: testcomplete 12.50 not recording

What type of application? If web, what browsers and their versions? What modules do you have licenses for? Has this worked before? 


Thanks,
Carson

Click the Accept as Solution button if my answer has helped
rmnrdi
Contributor

Re: testcomplete 12.50 not recording

It's a Delphi Desktop app and I was able to record keystrokes yesterday.

cunderw
Community Hero

Re: testcomplete 12.50 not recording

Has anything changed between yesterday and today?

 

Can you see any of your applications objects in the object browser? 


Thanks,
Carson

Click the Accept as Solution button if my answer has helped
rmnrdi
Contributor

Re: testcomplete 12.50 not recording

I don't know what would have changed so TC doesn't recognize keystrokes. What are common causes of this?

 

Yes. I can see my application objects in the object browser.

cunderw
Community Hero

Re: testcomplete 12.50 not recording

A number of things really could cause this, which is why I was asking if you know personally of anything in your environment that may have changed, there are a lot of moving parts so just trying to narrow down what changed to troubleshoot those areas first.

 

Do you still have the Desktop module installed? If you go to File > Install Extensions do you see Desktop checked as well as Delphi application support underneath desktop?

 

Also, it may sound silly but have you simply tried rebooting the machine you are recording on?

 


Thanks,
Carson

Click the Accept as Solution button if my answer has helped
rmnrdi
Contributor

Re: testcomplete 12.50 not recording

Not silly at all.

 

I can't think of any environment changes and I tried rebooting as well as re-installing. 

 

I said earlier that it recognized my objects, but it only shows them in the tree. When you click on them in object browser it just shows a black space where the object picture should be.

cancel
Showing results for 
Search instead for 
Did you mean: