Ask a Question

Windows 10 apps

Occasional Contributor

Windows 10 apps

Hi there! 


I have a question regarding Windows 10 applications. Is it possible to get into, for example, the objects/elements of the Windows 10 calculator? I would like to know, because we have an UWP application, which can be installed and launched in Windows 10. But we face the same problem with our application. In TestComplete it shows as "Windows.UI.Core.CoreWindow", which is a default in the UI Automation settings. However, it is impossible to get into the main window and see child objects 😞 

It is possible to spy and see children of the top menu bar (minimize,maximize,close), but not the actual main window (Windows.UI.Core.CoreWindow). The applications are both showing as process "ApplicationFrameHost". 


I have done and tried everything, also the suggestions mentioned here:


Could someone please clear this up for me? 🙂


Kind regards!

Champion Level 3

If you've followed everything in that requirements link and are still having issues, I would contact Support directly.  Here's their link:

SmartBear Alumni (Retired)

Thank you Marsha!


Hi @Frits ! I found your support case (00472117) where you mentioned that you solved the issue! Could you share your solution with us?

Sonya Mihaljova
Community and Education Specialist

Occasional Contributor

Hi Sonya!

The problem was the following option: (TestComplete shortcut > right-click > Properties > Compatibility > “Run this program as an administrator”). When this option is active, it doesn’t work. Neither when I double-click the shortcut, nor when I right-click the shortcut and “Run as administrator”.

However, when I disable this option it always works fine. So when the option is disabled and I double-click the shortcut it works fine, and it also works fine when I right-click the shortcut and “Run as administrator”.
Showing results for 
Search instead for 
Did you mean: