Ask a Question

TestExecute 15.20 + Jenkins issue

SOLVED
Nikolayev
Contributor

TestExecute 15.20 + Jenkins issue

Hi Community ! 

 

Can you help please ? 

 

We just upgrade our server with the latest TestExecute version 15.20  but had to rollback to previous one 14.91 because of this issue when we launch a JOB : 

 [TestComplete] Test runner exit code: -14 (An unsupported version of the TestComplete Service is running on the node. Please use TestComplete Service version 10.60 or later 

 

Thank you for help

 

 

5 REPLIES 5
vinniew
Staff

Hi @Nikolayev 

 

I think I know this issue. 

 

Are you using the TestComplete support plugin on Jenkins?

 

If yes, navigate to your workspace>configure>Build(this is the testcomplete part) > select Advanced

 

Here you will see the details for the runner whether its TestComplete or TestExecute 

 

You will also see version, For here I would recommend using the "latest" option in the drop down

 

If you are using pipeline script you instead of a job you will just need to change the command line arguments 

 

Reference TestComplete 15 instead of 14.

 

That should solve your issue 

 

KR

 

Vinnie

Hi @vinniew 

Thanks for reply

We are looking also with our Jenkins version. It is 2.6.2

https://plugins.jenkins.io/TestComplete/

 

Hi @Nikolayev 

 

No problem, check the configuration of the job. 

 

I suspect that is the the cause of the error you got when you upgraded. 

 

I had something similar when I updated TC a few weeks back. 

 

I hadnt changed/updated the jenkins configuration, it was set at version 14 and not "latest"

 

Let me know how it goes anyways 

 

KR 

 

Vinnie

@vinniew  it is well configure to "LATEST" .

With my colleague, we see that the jenkins test runner was not updated

We were in release 2.6.2  so we install release 2.8.1 

now I don't understand the thing's happening,    It looks like "Doctor Strange" is with us 🙂 

I'll explain you :

 

after install 2.8.1 jenkins TestExecute version

I install again the 15.20 version of TestExecute andremove the 14.91

Installation is OK , I launch a job. I still have this :  

[TestComplete] Test runner exit code: -14 (An unsupported version of the TestComplete Service is running on the node. Please use TestComplete Service version 10.60 or later)

 

here are the line above this error where we can see the installed TestExecute versions : 

[TestComplete] Found TestComplete/TestExecute installations:
	Type: TE, Version: 15.20.341.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe"
	Type: TELite, Version: 15.20.341.50, Path: "C:\Program Files (x86)\SmartBear\TestExecuteLite 15\x64\bin\TestExecuteLite.exe"
[TestComplete] Selected TestComplete/TestExecute installation:
	Type: TE, Version: 15.20.341.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe"
[TestComplete] Launching the test runner.
$ '"C:\Program Files (x86)\SmartBear\TestExecute 15\bin\TestCompleteService15.exe"' //LogonAndExecute //lDomain: "" //lName: "UT_AUTO_TESTCOMPLETE@gpsi.fr" //lPassword: ******** //lTimeout: "-1" //lUseActiveSession: "true" //lCommandLine: '""C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe" D:\DevGit\TA\NOVA\GAIA-NOVA-THEIA\GAIA-NOVA-THEIA.pjs /run /SilentMode /ForceConversion /ns /exit /ExportLog:D:\DEVGIT\TA\NOVA\1642589983478.tclogx /ExportLog:D:\DEVGIT\TA\NOVA\1642589983478.htmlx /ErrorLog:D:\DEVGIT\TA\NOVA\1642589983478.txt /ExportLog:D:\DEVGIT\TA\NOVA\1642589983478.mht /project:GAIA-NOVA-THEIA /test:KeyWordTests|F1_0001_Ouverture_Fermeture_NOVA /DoNotShowLog /JenkinsTCPluginVersion:2.8.1"'
[TestComplete] Test runner exit code: -14 (An unsupported version of the TestComplete Service is running on the node. Please use TestComplete Service version 10.60 or later).
[TestComplete] [WARNING] Unable to find the log file "1642589983478.tclogx".
[TestComplete] [WARNING] Unable to find the log file "1642589983478.htmlx".
[TestComplete] [WARNING] Unable to find the log file "1642589983478.mht".
[TestComplete] [WARNING] Errors occurred during the test execution.

 Then after that error, I install again TestExecute 14.91 without uninstall 15.20 :

I run a test thinking it will fail because running with the latets (my test is set to " LATEST")

But not !   the test returns OK  . I don't understand 

Here is the log with 14.91 and 15.20  :  

 

[TestComplete] The test execution started (GAIA-NOVA-THEIA/GAIA-NOVA-THEIA/KeyWordTests|F1_0001_Ouverture_Fermeture_NOVA).
[TestComplete] Found TestComplete/TestExecute installations:
	Type: TE, Version: 14.91.341.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 14\x64\bin\TestExecute.exe"
	Type: TE, Version: 15.20.341.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe"
	Type: TELite, Version: 14.91.341.50, Path: "C:\Program Files (x86)\SmartBear\TestExecuteLite 14\x64\bin\TestExecuteLite.exe"
	Type: TELite, Version: 15.20.341.50, Path: "C:\Program Files (x86)\SmartBear\TestExecuteLite 15\x64\bin\TestExecuteLite.exe"
[TestComplete] Selected TestComplete/TestExecute installation:
	Type: TE, Version: 15.20.341.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe"
[TestComplete] Launching the test runner.
$ '"C:\Program Files (x86)\SmartBear\TestExecute 15\bin\TestCompleteService15.exe"' //LogonAndExecute //lDomain: "" //lName: "UT_AUTO_TESTCOMPLETE@gpsi.fr" //lPassword: ******** //lTimeout: "-1" //lUseActiveSession: "true" //lCommandLine: '""C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe" D:\DevGit\TA\NOVA\GAIA-NOVA-THEIA\GAIA-NOVA-THEIA.pjs /run /SilentMode /ForceConversion /ns /exit /ExportLog:D:\DEVGIT\TA\NOVA\1642590626837.tclogx /ExportLog:D:\DEVGIT\TA\NOVA\1642590626837.htmlx /ErrorLog:D:\DEVGIT\TA\NOVA\1642590626837.txt /ExportLog:D:\DEVGIT\TA\NOVA\1642590626837.mht /project:GAIA-NOVA-THEIA /test:KeyWordTests|F1_0001_Ouverture_Fermeture_NOVA /DoNotShowLog /JenkinsTCPluginVersion:2.8.1"'
[TestComplete] Test runner exit code: 0.
[TestComplete] The test execution finished (GAIA-NOVA

 

What should we have to do ?

 

 

Hi again @vinniew  

 

We have seen that a new TestExecute version 15.30 just realised 

We tryed with this one , Everything is fine with that one, Problem Solved.

 

I had 2 cases with the support  : #00504239 and  #00504682

 I will informe they can close the cases

Thank you for Help !

cancel
Showing results for 
Search instead for 
Did you mean: