Ask a Question

TestComplete stopped regognizing objects

SOLVED
dennis1
Occasional Contributor

TestComplete stopped regognizing objects

Hi,

 

For some reason Testcomplete does not regognize the objects in my application anymore.

All the objects are mapped and worked about a week ago. Now it only regognized the entire window of the application. No updates were done either to TestComplete or the tested application.

 

I am running these tests on two identical machines with same version of the application. On one it works perfectly fine, on the other one it does not regognize any objects anymore.

 

The only difference is that on the currently working machine I have Tescomplete 12.5 installed, and on the machine that stopped working i have 12.6 installed.

1 ACCEPTED SOLUTION

Accepted Solutions
dennis1
Occasional Contributor

Re: TestComplete stopped regognizing objects

Thank you for your replies.

 

The solution for me was to reinstall the application and testcomplete itself.

 

 

View solution in original post

4 REPLIES 4
AlexKaras
Community Hero

Re: TestComplete stopped regognizing objects

Hi,

 

My opinion is that this is near to impossible situation.

You should pay more attention and find out what was changed. TestComplete and your tested application are not the only things that exist on the problematic system. OS updates, domain policy changes, some missed extension in TestComplete, ...

 

P.S. I believe that you have rebooted the problematic system, haven't you?

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
Vallalarasu_P
Frequent Contributor

Re: TestComplete stopped regognizing objects

I'm not able to answer exactly for the problem. But you can check the below two options

1. Any Anti virus installed.

2. Dot Net framework version on the machin installed is different.

With Regards
Vallalarasu Pandiyan
https://www.linkedin.com/in/vallalarasupandiyan/
tristaanogre
Community Hero

Re: TestComplete stopped regognizing objects

To go along with @AlexKaras, something has changed.  What type of application is this?  Delphi? .NET? Web?  I would also check licensing on the two machines.  Do they have the same modules?  Like is one Desktop only and the other Web only?

 

There's something different on the two machines and it's not simply TestComplete version.  Time to play detective and figure out what's different.  We can help, but we need more info.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
dennis1
Occasional Contributor

Re: TestComplete stopped regognizing objects

Thank you for your replies.

 

The solution for me was to reinstall the application and testcomplete itself.

 

 

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: