Ask a Question

TestComplete cannot find visible buttons

New Contributor

TestComplete cannot find visible buttons

Hello everybody,

I'm testing an application using TestComplete 14.0 on a Windows 10 computer. The application is a software controller built using Qt 5.14.2 libraries and compiled using Visual Studio 2017.

We recently upgraded the Qt libraries from Qt 5.8.0 and TestComplete cannot find some buttons anymore. Even though, those buttons are completely visible.

I've run the Report Generator application and produced a report about this issue. Also I'm attaching a screenshot about what I'm talking about. Basically, Test complete says that it can't find a button on a Popup that is visibile, saying that is not.

What could cause this issue? I've checked the button with the object inspector and the name of the button showed fits with the action selected.


Any help is appreciated.


Esteemed Contributor

First of all, this is a user-based forum so things like that report file aren't going to get much traction here... guys like me are just users like you and don't have the fancy tools that SmartBear support actually has.


That said, according to, QT support is only available up to 5.12 in version 14.4.  Any versions beyond 5.12 are not currently supported by TestComplete.  That's where your visibility problem is.  

You can still automate your application but it will take some reworking to use things like keyboard navigation, hotkeys, visual component identification, and OCR.

To head off your next question: To get support for QT 5.14 you should create a Feature Request here on the forums and, potentially, follow it up with a message to SmartBear directly.

Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

have you tried modifying some of the unexpected window responses in the tools->current project properties-> playback> (then some radio buttons)

typically unchecking the options of press esc, press enter, and send close command takes care of these (invisible pop up errors)



Justin Kim

Ok, sorry for the report. I thought it could be useful. I'll try to reach official support, then.

In any case, the issue comes only with those popup buttons, and nothing else. Also, sometimes it works sometimes not.


I'll try to find a way to workaround those problems, because changing the Qt libraries version, is way harder.


Thanks for the hints, by the way.

New Contributor

Already stumbled in those, some time ago, but not tried now.

I'll definitely try switching those flags and see if anything changes.


Thanks for the tip!


SmartBear Alumni (Retired)

Thank you for helping Community!


@AleRao  Please let us know how you solved the issue!

Sonya Mihaljova
Community and Education Specialist

New Contributor

Sorry for not answering first. Solution was to find the object in Name Mapping Editor, once found, I've edited the proprierties adding "Visibile" and "VisibleOnScreen" both equal to true.

Depending on the button "VisibleOnScreen" may be false. In that case I've added only the "Visibile" property.

Showing results for 
Search instead for 
Did you mean: