Ask a Question

Seeing huge resource consumption in TestCompleteService15 (32 bit) causing VM to be unstable

nathanginoza
Contributor

Seeing huge resource consumption in TestCompleteService15 (32 bit) causing VM to be unstable

Snag_1aa7c3ca.png

Snag_1aa7e1d1.png

Seeing 90% to 100% CPU usage, this is causing connection to VM to hang.

 

See this in All VMs where TestComplete / Execute is installed and upgraded and projects upgraded.

 

Anyone else seeing this blocking issue?

 

Nathan

 

8 REPLIES 8
nathanginoza
Contributor

100% TestCompleteService usage even when scripts not running.

seeing this in task manager. Any ideas /  workarounds?

 

Snag_1aadf55c.png

tphillips
Frequent Contributor

Re: 100% TestCompleteService usage even when scripts not running.

Can you describe the circumstances under which this happens? What were you doing in TestComplete at the time?


--------------------
Senior SQA Automation Engineer
tphillips
Frequent Contributor

Re: Seeing huge resource consumption in TestCompleteService15 (32 bit) causing VM to be unstable

What sort of resources are assigned to the VM? What were you doing in TestComplete at the time? What if you close down and restart TestComplete, can you reproduce the behaviour?

 

Also this is the wrong forum to post this issue in 🙂 it should probably be in TestComplete Questions.

Is this issue also related to the other issue you posted? https://community.smartbear.com/t5/TestComplete-Questions/100-TestCompleteService-usage-even-when-sc...


--------------------
Senior SQA Automation Engineer
Marsha_R
Community Hero

Re: Seeing huge resource consumption in TestCompleteService15 (32 bit) causing VM to be unstable

hi @nathanginoza 

 

I combined your two posts since they seem to be related, and I moved them to our new Questions board.  

 

Once we see your answers for @tphillips questions, we can help a little more.  


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
nathanginoza
Contributor

Re: Seeing huge resource consumption in TestCompleteService15 (32 bit) causing VM to be unstable

Thanks for the response,

 

Trying to repo, it happen when I ran scripts in the background using system disconnect. 

mcbane
Occasional Contributor

Re: 100% TestCompleteService usage even when scripts not running.

I keep my version of TestComplete up to date. I had not seen this issue until this morning. I killed the service and rebooted to fix it early this morning. It has now happened a second time on my virtual PC. I don't know that I have anything to add. Just wanted to make sure it is known that it's not an isolated incident. Thanks!

 

Tommy

mcbane
Occasional Contributor

Re: 100% TestCompleteService usage even when scripts not running.

I just realized that I can clarify some of the questions being asked.

 

At the end of the day, I reboot my virtual PC so it is fresh the next morning. When I tried to log on to it this morning, it took 5 minutes (as opposed to 5 seconds). TestCompleteService15.exe (32-bit) was using over 95% of the CPU, where the virtual PC rarely sees more than 25-30% usage. TestComplete was NOT running. I killed the service. Rebooted. And was fine.

 

This afternoon, I was running a test when the usage shot up again. I closed TestComplete, and my virtual PC was still SLOOOOOW. I checked the task manager and it was TestCompleteService15.exe (32-bit) again. I killed it again.

 

That's about it for now.

tphillips
Frequent Contributor

Re: 100% TestCompleteService usage even when scripts not running.

Wow it definitely sounds like it might be worth raising an issue with support

 

https://support.smartbear.com/testcomplete/message/


--------------------
Senior SQA Automation Engineer
cancel
Showing results for 
Search instead for 
Did you mean: