Ask a Question

Object causing exception during test run

Frequent Contributor

Object causing exception during test run

Hi all, 


I'm having an issue running a test where an object is continually causing an exception. 


The object can be found by clicking the "Highlight" option from the right click menu from the Namemapping tree. So appear no issues with the mapping.

I have added a waitproperty operation to the test ,to wait until the object exists, the exception still occurs on the object.

I have added a delay to the test to allow the object to load, the object still causes an exception.

I have added interactions  with other page objects on the same webpage to the test, before interacting with the required object,  object still causes an exception.


In the keyword test log, "Details", the only message I am getting is "Member not found"


Any ideas on this? is there a remedy for it?







@ThomasCasserly wrote:

Hi Alex, 


I have no idea, how would I find it? FYI I'm using keyword tests in case that makes a difference.

Hi @ThomasCasserly - I was answering your question to Alex about finding the code line that causes the error, because you said you didn't know how to find it.   Now you do!

Hi Alex,


It's definitely an "Exception" that is occurring and  not "Object not found". The message under the details tab in the keyword test log reads "Member not found".


I'm attaching the log files here in a Zip.


I'm not a coder, but from your explanation, I tried changing the Item on the WaitProperty operation to be the top level parent (to prevent the loop??). Also spotted that the value I was using for the Wait Property operation was an Object property (which I think is what you were explaining 🙂) so I changed it to be a boolean constant, ( I usually use Boolean constants on WaitPropeprty operations, just a mistake here on my part). However I still get the exception error. Screenshot for change I made  to "Item" and "Value" is also attached. 


What I'm expecting to happen is that the script waits until the Exists property is true for the Item and then continues running the Keyword test. I have read the help article on WaitProperty operations but maybe I'm doing it wrong.



Ah, ok, thanks Marsha. I thought "code line" was something to do with viewing the test as script, not that it was just the keyword test line  🙂



So i just found the problem myself, I hadn't selected the "Exists" property of the Object, but had only selected the object itself.

Once I Selected the Object, and set the "Exists" property as the value the Exception no longer occurs.


User error this time (must be the first time ever 😋😅😅)


Thanks all for pointing me in the right direction and helping me find "my own" issue🙈🙈🙈

Showing results for 
Search instead for 
Did you mean: