Ask a Question

Object being reference but not working in script

srijansameer11
New Contributor

Object being reference but not working in script

Hi Team,

The following object is being highlighted on the screen but when the same object is being used in script with ClickR() function which is a method available. It says the object not found, I have also implemented MSAA to enable me to access the child object.

 

Object: 

srijansameer11_0-1631728064040.png

Script:

srijansameer11_1-1631728179203.png

 

 

6 REPLIES 6
Marsha_R
Community Hero

Re: Object being reference but not working in script

Here are some troubleshooting steps.  See if these help:

https://support.smartbear.com/testcomplete/docs/testing-with/running/handling-errors/object-not-foun...

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
anupamchampati
Frequent Contributor

Re: Object being reference but not working in script

Also try to Debug just before the click operation to check whether the object name changes dynamically. if yes try to Use some unique identifier for that particular node.

sonya_m
Community Manager

Re: Object being reference but not working in script

Thank you for being so helpful, Community!

 

@srijansameer11 did this help you solve the situation?


Sonya Mihaljova
Community and Education Specialist

Join Wintertainment 2021 to share your stories, have fun, earn community badges, and more!
srijansameer11
New Contributor

Re: Object being reference but not working in script

Nope

Marsha_R
Community Hero

Re: Object being reference but not working in script

Which steps did you try and what happened when you did?

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
sonya_m
Community Manager

Re: Object being reference but not working in script

Hi @srijansameer11 ! The Community needs more info from you to provide further guidance, could you share the details?

If you already solved the issue, please share the solution here, thank you.


Sonya Mihaljova
Community and Education Specialist

Join Wintertainment 2021 to share your stories, have fun, earn community badges, and more!
cancel
Showing results for 
Search instead for 
Did you mean: