Ask a Question

Not able to scan dropdown values of addins we have created for Microsoft PowerPoint


Not able to scan dropdown values of addins we have created for Microsoft PowerPoint

When I click on QuickStart , I am not able to capture properties of the content mentioned in dropdown . Please refer attach screenshot


Hi @Jainsoumya 


Hope you are well.


You can use MSSA for extending recognition capabilities


I have checked and this works in powerpoint. 


To test, click on project properties > Open applications > MSSA.


If you just want to test if it works check the astrix just to expose all MSAA windows in all processes.


This will verify that it works for object recognition.


From there I would recommend adding a rule (list of accepted windows) to the current MSAA configurations followed by unchecking the astrix. 


This is due to the astrix exposing all processes running on your machine which could lead to performance issues. 


it should something like a wnd class item you need to add however if you are unsure of the class use something like “ *testedapp.exe* ” where testedapp is the same name of your applications main process (under test (check object browser if you’re unsure)


Hope that helps 



Hi @vinniew 

No , its not working.

The test step which was working earlier not that also not working.

Check the screenshot 




Hi @Jainsoumya 


My response was based on your initial query which was in relation to further exposing properties. 


MSSA extends what we support out of the box. 


If you have just enabled it you will then need to re-record your flow as the mapping criteria will be different.








I have re recorded it and then when I ran the test step its getting failed with the error class not found 

Hi @Jainsoumya 


I tried it again and it worked for me. 


I am not sure why it is not working for you but  perhaps reach out to your SmartBear rep to arrange a quick call with an engineer. 


Otherwise raise a ticket with support.





Hi @vinniew 

I am getting such error 




I have raised the incident , support engineer provided me the solution of MSAA and UI Automation

I think MSSA works here but your checkpoint (validation) looks to be checking for an older property...


With MSSA enabled its picking up a different property value using MSSA


In other words if you go to the log of the error, 


There should be a link in the details of the log to update the checkpoint with the new found value. 


Afterwards that checkpoint will pass





Showing results for 
Search instead for 
Did you mean: