Ask a Question

Keyword Test: Data is not stored in variable after defining 'Set variable value' and 'log'

SOLVED
HarishN123
New Contributor

Keyword Test: Data is not stored in variable after defining 'Set variable value' and 'log'

Hi Team,

 

Could you please provide solution for below query?

 

I need to extract text (Service Order Number) from a web page control and store it in a variable. So that I call same variable in another test. I have defined 'Set variable Value' for storing value in the first test and working fine. I can see value in log message as well. But value is not storing in variable. Below are screenshots.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Marsha_R
Community Hero

Re: Keyword Test: Data is not stored in variable after defining 'Set variable value' and 'log'

If you are displaying the variable in the log and the value is there, then it is being stored.  I agree with @VeenaDevi that maybe you are not looking in the right test.  Try adding some text to your log messages that will help distinguish one from the other.


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame

View solution in original post

2 REPLIES 2
VeenaDevi
Contributor

Re: Keyword Test: Data is not stored in variable after defining 'Set variable value' and 'log'

whether you are recalling the variable in same test or different test , based on that create persistent variable , that too in Project level.

Marsha_R
Community Hero

Re: Keyword Test: Data is not stored in variable after defining 'Set variable value' and 'log'

If you are displaying the variable in the log and the value is there, then it is being stored.  I agree with @VeenaDevi that maybe you are not looking in the right test.  Try adding some text to your log messages that will help distinguish one from the other.


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: