Ask a Question

Infragistics object not recognised by TestComplete

hiepwork08
Contributor

Infragistics object not recognised by TestComplete

Hi,

I am using TestComplete on an application which predominantly uses the Infragistics plugin.

I am encountering an issue with the Table Checkpoint whereby the application object which I want TestComplete to tablised is not recognised despite me mapping the object using the Object Mapping feature.

Some objects are recognised but not every object.

I think it has to do with the way the application under test inherits the Infragistics plugin.

Is there a way to get around this so TestComplete recognises all objects when using the Table checkpoint.

 

Checkpoints which I find currently not recognised include UltraTree and lists with child branches.

 

3 REPLIES 3
Marsha_R
Community Hero

This may be helpful

 

https://support.smartbear.com/testcomplete/docs/general-info/supported-technologies/controls/infragi...


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame

Looking at the list suggests the Infragistics object is supported.

What I don't understand is to what extent if developers inherit the object class but then expands the object class and wraps it then will TestComplete still recognise it.

What I am finding is that the developers are saying they inherit from the UltraTree class, but somehow TestComplete is not recognising all the lower levels 'nodes' of the tree when using the Table checkpoint. It only recognise the top level rows and columns but not child rows and columns.

Still an issue despite me using the Object mapping feature.

I should add its the case where a table within a table then the inner table rows are not recognised.

cancel
Showing results for 
Search instead for 
Did you mean: