Ask a Question

Error: Object not a collection


Error: Object not a collection

When using the FindAll method I am getting the runtime error - Object not a collection. This only occurs on certain Windows 10 machines and only when using specific scripting languages.




Out of the four machines I've tried it on, two will get the error when using C++Script, C#Script, JScript or VBScript. If using Python or JavaScript it will work. On the other two machines FindAll works correctly for all languages.


This is done using a new project and using the FindAll example from the help file. Does anyone have an idea what could be causing this?


All PC's are running:
TestComplete 12.1
Windows 10 Pro, Version 1903, Build 18362.592


@Marsha_R It only works when stepping through the code if you switch to the locals tab and expand the actual object that is causing the error. If you don't expand it, or are viewing the call stack, watch list or breakpoint tab it will still show the error. I know all the ways to get around any timing issues, I've tried them all and unfortunetely nothing works. 


I just need to put this down to the fact I'm using an older version of TestCompete and it's not going to work forever. Some Windows/third party update is bound to cause issues sooner or later, might be time to finally upgrade. 



SmartBear Alumni (Retired)

I believe that updating TestComplete is a good idea in this situation. Do let us know how this works for you.


The devs are adding a lot of fixes and enhancements to each release, so I expect you see improvements in many areas after the updateSmiley Happy

Sonya Mihaljova
Community and Education Specialist

Showing results for 
Search instead for 
Did you mean: