Ask a Question

Chrome v. 44...


Chrome v. 44...

So, my Chrome auto-updated (thanks Google...) and TestComplete doesn't seem to be able to handle it.  Is there a patch oncoming, or has anyone found a workaround (doubtful, but you never know).  Thanks!




> Thanks for the alternate method for disabling updates in Chrome, Alex.

Not at all and good to know that it still works 🙂

Also, thanks for the note about 'no update' policy... Just thought that maybe the policy must be updated somehow after manual Chrome install..?


 > ran <version>/Installer/setup.exe, but it did not appear to do anything.

Well... Not good but thank you again for trying this and sharing your results.




  /Alex [Community Hero]
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
Frequent Contributor

I tried resetting the policy with no result.  Appears to be an actual issue, as far as I can tell:





I've done it numerous times. It never works. Never has for me.


Alex's folder method seems to be just the job tho. 🙂

Unfortunately not even this method of deleting the Update folder is bullet-proof. I have stayed on v.43, but had to downgrade once or twice, even though I deleted the folder.


So, just a heads up: you still need to save the manual loader even though you use this method. Downgrading is quite easy, though, once you get the routine. And of all the methods to prevent auto-upgrade this seems to be the fastest and most efficient.

Sha is right.


Chrome in my VM somehow managed to update itself to v45, even with the "Update" folder removed.


Although, oddly, the Chrome install on my physical machine, which also has the "Update" folder removed has not updated. Why it did on one and not the other is a complete mystery to me.


Anyway, I had an offline installer for v43. So I uninstalled v45 and re-installed. I did remember I needed to re-enable the TestComplete plugin, which I did. But I initially forgot you also need to re-enable NPAPI support in Chrome. It dawned on me after a further two uninstall and reinstalls.


NPAPI instructions:


Just thought I'd post this up in case anyone else forgot about it!

And having downgraded the VM back to v43 yesterday afternoon, I've just gone to run something this morning and Chrome has updated to v45 again somehow?!?!?


Physical machine still on v43.


Both physical machine and VM were left on, but locked, overnight. The VM resides on the physical machine.


I think I'll adjust the update policy document on the VM as well as removing the folder. I can't think of any other reason why one keeps updating and the other doesn't.


Man I hate Chrome ....

Further update ....


This time, after un-installing, my offline installer (same one I used yesterday) failed.


The un-install clearly wasn't clean. I had to go in and delete the registry entries as per the first reply here:


... to get the installer to work again.


Chrome does like to make things difficult doesn't it.


Now re-installed and as well as removing the update folder (it just created a new one overnight) I'm going to also update the policy document (and old method to try and stop it updating) to see if that helps. I can't think of any other reason why the VM updates when the physical machine does not ...

Last time I had the problem, I formed a hypothesis, which may be unfounded: Possibly it is some event that my test provoked (a server crash or similar) that triggers an update from within the Chrome browser itself and not the code in the update folder (as part of error handling). Does this make sense. did your test fail in ways that may have triggered error handling in the browser?


I do not currently have the problems you mention, so it is not some 'global issue'. I had to downgrade to 43 on all my servers within a the span of 2-3 days a week ago, but it has been OK since. (And I am about to move to 45 now).



Nope. Tests yesterday are ones I've been running for many months. Well proven. Ran clean.


When I went home it was on v43 (and not running anything last night) and idle. Came in this morning and the VM (only the VM) had gone to v45.


Back to v43 again now. We'll see how long it hold up this time ....

Not long.


My test (small one) finished on v43. Worked perfectly.


Just gone back into Chrome on the VM (less than an hour after the test completed) and Chrome has already updated itself to v46. So it appears to be impossible to stop it now. On the VM. For some reason. Physical PC is still showing v43 ......


I updated the policy document, the regsitry, and deleted the Update folder. It still found a way. I hate it.

Showing results for 
Search instead for 
Did you mean: