Ask a Question

$ref (erencing) a valid OAS3 domain file not working

Occasional Contributor

$ref (erencing) a valid OAS3 domain file not working

I have a Domain defined in OAS3 of 472 code lists containing 14,456 code values(enums).

I'm trying to reference this from my API spec which is validating correctly except for this one $ref defined in the following format as recommended at the following support page...





        $ref: ''




When I enter ...

into the browser it correctly jumps into the domain to the component defined .


I thought maybe the size of the domain may be an issue since swagger is slow at validating so I pulled out just one schema component into its own domain, referenced just that one and still have the same error when validating the referencing API.


Any help most appreciated!

Champion Level 2

I am not sure about Size limitation (We should wait for a clear statement from Smartbear)
In the meanwhile, can you share a sample?

Occasional Contributor

Hi @chichepo ,

Example attached.

API defines a parameter of a type defined locally in API components/schema which in turn references an enumerated list in the codelists domain file.


I tried the files but I am unable to reproduce the issue.

The API file here is using a string property transactionTypeCode referenced in the Domain here





I missed something?





Occasional Contributor

@chichepo , you haven't missed anything. This is exactly as I've configured it in my cloud account and as with mine, when I click on the link to the API file you've published and expand the policy renewal quotation process operation it hangs and times out throws timeouts.


If it's working for you perfectly then perhaps there's an issue with my networks config? I'l see what SmartBear come back with.

Thanks for testing out in your account. Much appreciated!

Indeed, it works well by me 🤔

Showing results for 
Search instead for 
Did you mean: