cancel
Showing results for 
Search instead for 
Did you mean: 

Swagger-jersey2-jaxrs dependencies deathlock

karcel
New Member

Swagger-jersey2-jaxrs dependencies deathlock

I would like to use https://mvnrepository.com/artifact/io.swagger/swagger-jersey2-jaxrs/1.6.2 in our project.

However we got some dependency issues which seems to be due to wrong backward compatibility of swagger parts. swagger-jersey2-jaxrs v1.6.2 requires dependency on https://mvnrepository.com/artifact/org.glassfish.jersey.media/jersey-media-multipart in version 2.25.1.

We do use multipart in version 2.29.1 but seems it is not compatible when using swagger-jersey2-jaxrs.
Latest version of multipart is 3.0.0.

Are there some insights of upgrading this dependency?

Thank you

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors