cancel
Showing results for 
Search instead for 
Did you mean: 

request parameters not appearing in SoapUI Pro

SOLVED
Highlighted
Contributor

request parameters not appearing in SoapUI Pro

I create a resource in the Projects tab, with a parameter.  I add to Test Case, but the parameter table is empty.  It says to use the project tool to add request parameters.  There is already a parameter with a name and value.  Why is my parameter not appearing is the test case?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Hero

Re: request parameters not appearing in SoapUI Pro

Hi @JeffSm 

 

I have had exactly the same behaviour occur when creating test steps.

 

What I found was that occasionally making a change in the UI wasn't persisted properly - i.e. add a query parm in the 'Projects' section of ReadyAPI!, navigate to the SoapUI tab and create a request based on the resource created in Projects, but the parms on the step are empty or the values were blank despite I thought I'd set them correctly.

 

What I noticed was that after I'd made the change in the Projects section (i.e. add in a query parm on the REST request whether at Resource or Method level) I moved the focus out of the field to a different field to ensure the value remained.  At this point I selected to Save all changes on the project.  I then continued to make the required changes - each time ensuring teh changes remained and I saved those changes.

 

hope this helps,

 

richie

 

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

2 REPLIES 2
Super Contributor

Re: request parameters not appearing in SoapUI Pro

@JeffSm ,

 

Can you please add any screenshot of the error.

 

 


Click "Accept as Solution" if my answer has helped, and remember to give "kudos" Smiley Happy

Thanks and Regards,
Himanshu Tayal
Community Hero

Re: request parameters not appearing in SoapUI Pro

Hi @JeffSm 

 

I have had exactly the same behaviour occur when creating test steps.

 

What I found was that occasionally making a change in the UI wasn't persisted properly - i.e. add a query parm in the 'Projects' section of ReadyAPI!, navigate to the SoapUI tab and create a request based on the resource created in Projects, but the parms on the step are empty or the values were blank despite I thought I'd set them correctly.

 

What I noticed was that after I'd made the change in the Projects section (i.e. add in a query parm on the REST request whether at Resource or Method level) I moved the focus out of the field to a different field to ensure the value remained.  At this point I selected to Save all changes on the project.  I then continued to make the required changes - each time ensuring teh changes remained and I saved those changes.

 

hope this helps,

 

richie

 

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post