cancel
Showing results for 
Search instead for 
Did you mean: 

Test suite doesn't end gracefully

SOLVED
Highlighted
New Contributor

Test suite doesn't end gracefully

Trying to run the entire test suite locally by launching the TestRunner, runs all the tests but doesn't end gracefully. I have added a HTTP timeout, but it doesn't seem to help either. The test console shows these warnings and hangs. Please let me know what is to be done to fix this.

13:38:58,501 WARN [JRConditionalStyleFillerFactory] Conditional style should not have an 'isDefault' attribute.
13:38:58,501 WARN [JRConditionalStyleFillerFactory] Conditional style cannot have a 'style' attribute.
13:38:58,501 WARN [JRConditionalStyleFillerFactory] Conditional style should not have an 'isDefault' attribute.
13:38:58,502 WARN [JRConditionalStyleFillerFactory] Conditional style cannot have a 'style' attribute.
13:38:58,506 WARN [JRConditionalStyleFillerFactory] Conditional style should not have an 'isDefault' attribute.
13:38:58,506 WARN [JRConditionalStyleFillerFactory] Conditional style cannot have a 'style' attribute.
13:38:58,695 WARN [JRConditionalStyleFillerFactory] Conditional style should not have an 'isDefault' attribute.
13:38:58,695 WARN [JRConditionalStyleFillerFactory] Conditional style cannot have a 'style' attribute.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Manager

Re: Test suite doesn't end gracefully

Hi @SomeNameQA,

 

I think it makes sense to follow the steps listed in the Optimizing Memory Usage article - they migth help you.

---------
Tanya Gorbunova
SmartBear Community Manager

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today

View solution in original post

3 REPLIES 3
Highlighted
Community Hero

Re: Test suite doesn't end gracefully

What sort of tests are these / what are they doing and/or testing? More details would be helpful in troubleshooting!




---

Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!
Highlighted
New Contributor

Re: Test suite doesn't end gracefully

These are API tests which run fine individually. They all actually pass. The issue is after the last API response is received and the test suite needs to end, it hangs (maybe while trying to generate a report of the tests?)

Highlighted
Community Manager

Re: Test suite doesn't end gracefully

Hi @SomeNameQA,

 

I think it makes sense to follow the steps listed in the Optimizing Memory Usage article - they migth help you.

---------
Tanya Gorbunova
SmartBear Community Manager

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
TechCorner Leaderboard
Want a fun and easy way to learn ReadyAPI and show off your skills? Try solving weekly TechCorner challenges and get into the Leaderboard!


Challenge Status

Compare an expected JSON value and actual response in Events

Participate!

Fetch value/data from JSON response using Groovy Script

See replies!

Filtering data retrieved from a DataSource

See replies!

Get data from Petstore and add it to Excel sheets

Participate!
Top Kudoed Authors