cancel
Showing results for 
Search instead for 
Did you mean: 

SoapUI Pro for Azure DevOps - Cannot validate argument on parameter 'ArgumentList'. the argument ...

SOLVED
Highlighted
New Contributor

SoapUI Pro for Azure DevOps - Cannot validate argument on parameter 'ArgumentList'. the argument ...

Dear All,

 

I have SoapUI Pro for Azure DevOps task successfully running in a Release pipeline.

 

The tests are passing, however the step "SoapUI Pro for Azure DevOps" shows an error : 

"Cannot validate argument on parameter 'ArgumentList'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command again"

 

I am using version *.2 of this task and the task "SoapUI Pro for Azure DevOps"  has only value in "

 
2019-10-01T16:50:17.4062767Z ##[debug]Exception:
2019-10-01T16:50:17.4134108Z ##[debug]Microsoft.PowerShell.Commands.WriteErrorException: Cannot validate argument on parameter 'ArgumentList'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command again.
2019-10-01T16:50:17.4417563Z ##[error]Cannot validate argument on parameter 'ArgumentList'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command again.
2019-10-01T16:50:17.4424887Z ##[debug]Processed: ##vso[task.logissue type=error]Cannot validate argument on parameter 'ArgumentList'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command again.
2019-10-01T16:50:17.4425441Z ##[debug]Processed: ##vso[task.complete result=Failed]
 
I found this article - https://community.smartbear.com/t5/SoapUI-Pro/SoapUI-Pro-for-Azure-DevOps-Tests-passing-task-failing... which says its resolved, but I couldnt actually understand what was done in order to resolve the problem.
 
Detailed steps around "Common.TestResultsDirectory variable" step, would be higly appreciated.
 
Thanks
 
 
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Manager

Hi @pravekdadhwal,

I see that you've got some help regarding the issue in this topic:

https://community.smartbear.com/t5/SoapUI-Pro/SoapUI-Pro-for-Azure-DevOps-Tests-passing-task-failing...

 

If it doesn't work for you, I recommend that you submit a support ticket to our Customer Care team:

https://support.smartbear.com/message/?prod=readyapi

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

1 REPLY 1
Highlighted
Community Manager

Hi @pravekdadhwal,

I see that you've got some help regarding the issue in this topic:

https://community.smartbear.com/t5/SoapUI-Pro/SoapUI-Pro-for-Azure-DevOps-Tests-passing-task-failing...

 

If it doesn't work for you, I recommend that you submit a support ticket to our Customer Care team:

https://support.smartbear.com/message/?prod=readyapi

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors