cancel
Showing results for 
Search instead for 
Did you mean: 

An error occurred when verifying security for the message-with an https web service

SOLVED
Regular Visitor

An error occurred when verifying security for the message-with an https web service

Hi All,

 

Web Services newbie here. When I put my WSDL in SOAP test, it comes back with 2 port names (WSHttpBinding_HylandOutBoundContract and BasicHttpBinding_HylandOutBoundContract) and each one has the same api call of "Getdocumentdata".
When i double click on that there is parmater thart asks for documentID, when enter a test dicument ID, i get the error response of "An error occurred when verifying security for the message". Upon searching the forumn I have come to this post (https://community.smartbear.com/t5/SoapUI-Pro/Trying-to-get-SoapUI-work-against-WCF-wsHttpBinding/m-...) and was wondering if I have the same issue, but before I go to the admin of the web services server, how do I know for sure that my https web services that --in order to read the response--I need to ask the web service admin to genertate a Ketstore protocol (i.e. a SSL keystore and password file)? And only then I can read the WSDL, however if there is another way to be able to read the response (REST or SOAP), please do let me know.

 

Thanks

-K

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Manager

Re: An error occurred when verifying security for the message-with an https web service

HI @katullus,

 

Please refer to the following KB article:

https://smartbear-cc.force.com/portal/KbArticleViewer?name=Is-wsHttpBinding-supported-in-ReadyAPI

 

You'll need to switch to the BasicHttpBinding binding.

---------
Tanya Gorbunova
SmartBear Community Manager

 Join SmartBear Connect next April in Boston to meet with software development, API and testing experts from around the world! Get your ticket today!

View solution in original post

1 REPLY 1
Highlighted
Community Manager

Re: An error occurred when verifying security for the message-with an https web service

HI @katullus,

 

Please refer to the following KB article:

https://smartbear-cc.force.com/portal/KbArticleViewer?name=Is-wsHttpBinding-supported-in-ReadyAPI

 

You'll need to switch to the BasicHttpBinding binding.

---------
Tanya Gorbunova
SmartBear Community Manager

 Join SmartBear Connect next April in Boston to meet with software development, API and testing experts from around the world! Get your ticket today!

View solution in original post