cancel
Showing results for 
Search instead for 
Did you mean: 

API1.5.0-SoapUI NG, there is always an alert"Out of Memory" or "No respoding

SOLVED
Occasional Contributor

API1.5.0-SoapUI NG, there is always an alert"Out of Memory" or "No respoding

1. I run scripts in  Ready! API 1.5.0 -Soap UI NG.

2. In the running process, an  alert  popup:"Out of  Memory" or  "Not Responding" , please see attachment

3. Would you please resolve it ? thanks  a  lot!

 

 

 

Monica

1 ACCEPTED SOLUTION

Accepted Solutions
Community Hero

Re: API1.5.0-SoapUI NG, there is always an alert"Out of Memory" or "No respoding

Check your java heap settings for ReadyAPI.
Increase the max heap size and see.
Below is the documentation link -
http://readyapi.smartbear.com/soapui/working/improving_memory_usage

Go to ReadyAPI-<version>/bin
Take backup of ready-api.bat/.sh based on OS platform.
Locate set JAVA_OPTS=%JAVA_OPTS% -Xms128m -Xmx768m -XX:MaxPermSize=128m

Increase -Xmx768m to -Xmx1024m or more as you needed.
And restart readyapi if it is running.


Regards,
Rao.

View solution in original post

3 REPLIES 3
Occasional Contributor

Re: API1.5.0-SoapUI NG, there is always an alert"Out of Memory" or "No respoding

anther screen shot

Community Hero

Re: API1.5.0-SoapUI NG, there is always an alert"Out of Memory" or "No respoding

Check your java heap settings for ReadyAPI.
Increase the max heap size and see.
Below is the documentation link -
http://readyapi.smartbear.com/soapui/working/improving_memory_usage

Go to ReadyAPI-<version>/bin
Take backup of ready-api.bat/.sh based on OS platform.
Locate set JAVA_OPTS=%JAVA_OPTS% -Xms128m -Xmx768m -XX:MaxPermSize=128m

Increase -Xmx768m to -Xmx1024m or more as you needed.
And restart readyapi if it is running.


Regards,
Rao.

View solution in original post

Occasional Contributor

Re: API1.5.0-SoapUI NG, there is always an alert"Out of Memory" or "No respoding

Thank you very much!

New Here?
Join us and watch the welcome video:
Watch the new Interview
Top Kudoed Authors