Showing results for 
Search instead for 
Did you mean: 

loading WSDL file

New Contributor

loading WSDL file



trying to load WSDL file.

gives error. 

Error: type 'something@urn:somethingelseTypes' not found.


The wsdl in browser shows.

<xs:import namespace="urn:somethingelseTypes"/>


I'm guessing this is issue. how do I fix this? Tried searching for answer, but couldn't find anything.



Community Hero

Re: loading WSDL file

Is the wsdl written by you ?

New Contributor

Re: loading WSDL file

Thanks for the reply.

No it's ERP system we use.

I kind of solved the issue. search more. what I did was copied the information into XML file

which still gave an error. found location where the error was, changed the code. 

Then used SoapUI to load the new file I changed. Worked. Now I just need to bug 

the company who wrote it, to fix their issue. 

Community Hero

Re: loading WSDL file

Hey @Chris_B,

For future reference if the .wsdl is either malformed xml or schema invalid the .wsdl wont load (which is the reason why your .wsdl was failing to load).

If you ever have this issue again, just launch your .wsdl in something like xmlspy (or a browser)....anything with am .xml parser would do to check the file.


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
New Here?
Join us and watch the welcome video: