cancel
Showing results for 
Search instead for 
Did you mean: 

Not all test steps run

vampirefish
Contributor

Not all test steps run

Hi .. I have a question... I have created a test suite and created a load test for a set of test steps.  I have ran each test step (11 total) individually with success.  However, every time I go to run all the steps in a load test, only a portion of them run.  Is there some setting I'm missing?  I've tried Simple and Fixed Rate.... still no success.  I'll continue to research but I need to resolve this ASAP as I'm testing today... this is the first time I've seen this.
3 REPLIES 3

Re: Not all test steps run

Hi!

could it be that they are failing and the testcase aborts (not running the remaining steps)? If not, can you attach a screenshot of the loadtest statistics so I can try to see what is going on?

regards!

/Ole
eviware.com


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
vampirefish
Contributor

Re: Not all test steps run

Thanks for this.. I've tried a few things... like disabling test cases.  At first I was able to select 'Detailed Error Information' for the load test report but now it's disabled.  Does this mean there are no errors if I can't select it?

I even added an assertion that fails but it's not showing up as an error.. is that correct?  I'm thinking it may be...   can you please let me know what you consider an 'error'?

Re: Not all test steps run

The failing assertion is not an error, and will not cause the teststep it occurs at to fail necessarily. Could you maybe send us the statistics from the loadtest run?

The actual project file would be very helpful as well.

Nenad
http://eviware.com


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors