Ask a Question

Startup Error

New Contributor

Startup Error

EVERY TIME I start up SoapUI lately, I get this error:
java.lang.ClassNotFoundException: com.eviware.soapui.SoapUI
at$ Source)
at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.exe4j.runtime.WinLauncher.main(Unknown Source)
at com.install4j.runtime.launcher.WinLauncher.main(Unknown Source)

if I uninstall, and reinstall it works, but as soon as I shut it down, and try to start it back up again, this error occurs.

Community Hero

More details please - what is the version of soapui, os, machine arch / bit length?
And can it be reproduced on different machine ? or only on your machine ?

New Contributor

Windows XP (32bit)
And I haven't tried it on any other machine, but it used to work great, until I upgraded to this latest version... I don't typically shut down my computer, so I didn't notice it until the other day.

when I go to the command prompt, and run the "soapui.bat" file, this is the error I get:

Error: Could not find or load main class com.eviware.soapui.SoapUI

I have looked through the batch file, thinking I could see if something was missed, but cannot find anything. Seems like it is all good?
New Contributor

Anyone got any ideas? it only works if i uninstall, and reinstall... and I can't even exit, without using the task manager...
New Contributor

I have the same error on my pc.

Anyone as discovered the cause of this error or have a solution?


my usage conditions are:


windows 7, 64 bit

error occurs with both soapui 4.6.4 and 5.0.0


the instalallation is done with no errors, soapui starts ok and for a while there are no problems.

after a while i notice that it is not possible no clone test-suites, for instance, and the close button does not work.

to terminate i have to choose the "exit without saving" option or terminate the process in task manager.


after that it is not possible to use the application normally. it does not start properly with the error message reported in this thread.

after search the instalattion directory i realised that some jars are missing (that explains the startup error)


windows firewall and anti virus application have not rule or report about soapui.


i have been installing soapui every week (sometimes more than once a day) for about 2 months... any ideias?

Anything useful in the logs other than the one showin in the first message in this topic? Did you use installer or zip file to install? May give a try removing previously created project and see the behaviour is same?


honestly a don't see anything very usefull in the logs.

this is all very strange. i have installed 5.1.2 and guess what? have to install 2 times on Monday, one yeasterday and right now the application is freezed again...


the jars in the application classpath are gone and there is no record of what happened.

i think it may be something caused by an antivirus (or even a virus) but i have no clue about the real cause.

the fact is that i will not be able to start soapui again unless i make another installation...


Hmm..Quite strange. Have you tried installing in other drive than 'C:'? Just it may be really a matter. Just to isolate if any policies that you might have or user has restrictions installing or modifying under C:\Program Files etc


thank you for replying to this queston and sorry for the late reply

after installing soapui 5.1.3 this error still happened, but i detected a pattern, and find out the error always started after the diary avg virus scanning.

avg reports soapui.exe as infected so i think that it was ignoring the exception rule that i defined as i installed soapui.


resuming, after some weeks of stress, thinking how in the world i would survive without soapui, the problem origin was the anti-virus software, one of the first things that i checked when the issue started, and after configuring another exception rule, this time for the base SmartBear directory, the problem is resolved and i'm again a happy soapui user.

Well done solving your issue and more importantly also sharing that information regarding potential issues with virus checkers, could help others - have some kudos! 🙂




Author of SoapUI Cookbook
Showing results for 
Search instead for 
Did you mean: