Ask a Question

SoapUI Project Deployed As War: global-groovy.log (Permission denied)

New Contributor

SoapUI Project Deployed As War: global-groovy.log (Permission denied)

I'm trying to deploy a SoapUI project as a war but I'm getting this error on the server it's deployed to:


2020-11-02T10:57:17.187979-05:00 utaurintrplt01 server: log4j:ERROR setFile(null,true) call failed.
2020-11-02T10:57:17.188448-05:00 utaurintrplt01 server: global-groovy.log (Permission denied)


I've deployed this same project before without issue but this is the first time trying with SoapUI Open Source 5.6.0. 

Community Hero

Hey @RTinkess31,

This is a total guess on my part but it looks like the issue is file permissions. Id have a look where groovy-global.log is being written and go from there, especially as it appears this issue was introduced on a new version of SoapUI



if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Showing results for 
Search instead for 
Did you mean: