Ask a Question

SoapUI 5.7.0: What latest Microsoft JDBC Driver for SQL Server to use for DB connection And Auth ?

jkrolczy
Frequent Contributor

SoapUI 5.7.0: What latest Microsoft JDBC Driver for SQL Server to use for DB connection And Auth ?

All,

 

I am currently using Open Source SoapUI 5.5.0 32-bit along with Microsoft JDBC Driver 6.0 for SQL Server
I am on a Win10 64-bit OS with java version 1.8.0_333

 

C:\Program Files (x86)\SmartBear\
SoapUI-5.5.0/jre/lib/sqljdbc42.jar
SoapUI-5.5.0/lib/sqljdbc42.jar
SoapUI-5.5.0/jre/bin/sqljdbc_auth.dll


I can currently do my needed SQL through my Groovy scripts and my REST request with Bearer authentication work fine as well.

 

I would like to upgrade to Open Source SoapUI 5.7.0 (which only 64-bit w/java seems to exists).

 

In doing so and I put my sqljdbc42.jar and sqljdbc_auth.dll (x64 version) in the same locations as SoapUI 5.5.0

everything does work correctly still except for this one line which I do not think is important ?

 

OpenJDK 64-Bit Server VM warning: Option --illegal-access is deprecated and will be removed in a future release.

 

If I move up in Microsoft JDBC Driver for SQL Server version:

 

https://docs.microsoft.com/en-us/sql/connect/jdbc/release-notes-for-the-jdbc-driver?view=sql-server-... 

 

example:  10.2 version files:   mssql-jdbc-10.2.1.jre8.jar    /    mssql-jdbc_auth-10.2.1.x64.dll

 

Placement of these 10.2 version files in the folder locations like I did with sqljdbc42.jar and sqljdbc_auth.dll

does not allow SoapUI 5.7.0 to work as I expect to should.

Database connection cannot be established.

 

Is there a change on how to define the groovy script   DB_connection = Sql.newInstance("jdbc:sqlserver .... ?

Should the files be placed in different folder locations?

 

Anyone setup OS SoapUI 5.7.0 in a manner I am trying - but that works for SQL through Groovy scripts ?

 

Thanks,

 

 

 

JamesK
0 REPLIES 0
cancel
Showing results for 
Search instead for 
Did you mean: