Ask a Question

Property transfer step failed when run through Maven

abhai
New Contributor

Property transfer step failed when run through Maven

Dear SmartBear Community,

 

I tried  Property Transfer in my REST Calls which works well in SOAP UI tool however when tried to run via Bitbash using POM Xml-  Maven plug 4.6.1, the Maven build failed due to unsuccesful Property Transfer .(Please find attached )

 

I tried to Property transfer the offer ID from a JSON response as shown below. The JSON path was set as $.offer.id in the Property Transfer section.(please see attached).

 

"offer": {
"version": 1,
"id": 81711,
"businessType": "NO",
"contract": null,
"organisationAssociations": [ {
"version": 1,
"id": 83711,
"organisationId": "01019",
"hackInitialOpportunityIdForSf": "DEI0200C98",
"crmReference": "%7B%22oid%22%3A%220064E000004JuEdQAK%22%7D"
}],
"country": "DE",
"documentLanguage": "de",
"availableTransitions": [
"invalidate",
"updateSps",
"modifyOfferData",
"modifyMainItem"
],

 

Also find attached the POM Xml file  and corresponding error message in Bitbash. 

 

Looking forward to hearing from you.

 

Abhai Josey Karottu

 

 

4 REPLIES 4
Debz
Contributor

Hi, 

 

I am a bit confused with the details you provided. It's posted in the Open Source forums but the declaration on the POM file is showing SoapUI Pro 4.6. If it's really open source and you just copied that XML and modified it for your variables, you might be missing some plugin declarations to make it work since the versions there seem to be a bit old. You might want to consider doing a backup and upgrading to 5.3.0. Anyway, it's free. They have already made a lot of fixes on that version to make life easier. If you still want to proceed with that version, you might need the following:

  • the plugin for Maven 2. Maven is now on version 3 though. I think they have already stopped support for 2...just a wild guess why the transfer is failing on your end only when Maven is run...so you'll be needing the items listed below.
  • @redfish4ktc2's plugin. He did some great work for some issues.
  • the compiler plugin...but you already have Java 1.8 so, just check the details there if it's still necessary since you have the latest one. We are working on an older version on our end so we are using this one.

Goodluck!

 

"an Engineer without a degree, a QA tester without any official certification (just yet πŸ˜‰ ) "
abhai
New Contributor

Hi Debz,

 

Thanks for your help and quick reply.Really appreciate it.

 

Yes,I am using a SOAP UI Open source version (5.3.0). I tried exactly as you advised me above but now unfortunately getting new errors. For example I tried Maven plugin 5.3.0 (<version>5.3.0</version>)in POM XML but  build failed as it was not possible to locate the corresponding plugin Jar file.(please see below)

 

Could you possibly send me one working sample POM XML for reference which includes all the latest required versions?

 

For your information .I have the following versions in my system.

 

  • Apache Maven 3.5.0
  • Java 1.8.0
  • SOAP UI 5.3.0

 

Thanks for all your efforts in advance.

 

Regards
Abhai

-------------------------------------------------------------

 

Error message for Plugin 5.3.0

Plugin com.smartbear.soapui-pro-maven plugin:5.3.0 or one of its dependencies couldnot be resolved.failure to find com.smartbear .soapui:soap ui-pro-maven -plugin:jar:5.3.0

 

abhai
New Contributor

Dear SmartBear Community ,

 

I tried all the available Maven plugin versions and voila ,Property transfer worked with V5.1.0 . Build was success however a new error related to double slash came up during the run.(Please see below )

 

11:35:49,665 ERROR [SoapUI] An error occurred [Double slash (//) in path], 

 

Thanks for your help in advance

 

Regards

Abhai Josey Karottu

nmrao
Community Hero

Is it causing the test fail?

May be see if this thread helps:
https://community.smartbear.com/t5/SoapUI-NG/Ready-API-1-2-Double-slash-in-path/td-p/102436


Regards,
Rao.
cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β