Ask a Question

Error Response return null while fetching more than 50,000 records over SOAPUI

Occasional Contributor

Error Response return null while fetching more than 50,000 records over SOAPUI

Hi All,

i tried to fetch around 300 records and it gets working but when i tried to fetch more than 50,000 records, an error occurred "Response return null"

Please provide me some support in case someone gets stuck with it.


Occasional Contributor

Hi all,
I found that the postman tool is not a recommended solution to fetch more than 65,000 records but it might be useful for small data. As I tried to fetch large data, postman kept crashed suddenly and didn't complete the process . However, it fetches small data (200-1000 records) but it didn't exceed more than that.
Anybody gets stuck with it and have a new approach for this case, please post it to be accepted as a new alternative approach.

@Coder : The URL which you are hitting is private or public?


If it is public could you please provide it to me so that i can try at my end and will let you know if i found something helpful?


Click "Accept as Solution" if my answer has helped,
Remember to give "Kudos" 🙂 ↓↓↓↓↓

Thanks and Regards,
Himanshu Tayal

Hey @Coder,

You say your request returns "null", but can you explain what that actually means?

When you check taskmanager, does the vm resource usage just continue to increase without plateauing?

Is there a way to filter the retrieved recordset so you only fetch a certain number of rows? The reason im asking this is that an exposed api that allows the user to retrieve 60k records is not really helpful to the user, so id expect perhaps a query parameter enabling you to filter the query to be avialable....or at least this is what ive found before now.

When you submit the request do you get any sort of response (http response code) or does it just hang and never finish?

Most testing tools are gonna struggle to retrieve 60k records cos unless theyve been opyimised to handle this number of records, the whole 60k recordset needs to be loaded into memory to enable it to display it.

If youre not getting a response at all and the request for the 60k records doesnt complete, id be interested in viewing the logging of your http/application server cos the problem could actually be at that end and NOT at the ReadyAPI!/SoapUI end. From your current description im starting to suspect the issue is the app server.


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Showing results for 
Search instead for 
Did you mean: