Ask a Question

very large HTTP GET Requests are getting ArrayOutOfBoundException: 4096 (HTTP/1.1 413 FULL head)

SOLVED
psy
Occasional Contributor

very large HTTP GET Requests are getting ArrayOutOfBoundException: 4096 (HTTP/1.1 413 FULL head)

With ReadyAPI  1.3.1 I get for my very large HTTP GET request an ArrayOutOfBoundException: 4096 -- formerly known in "old" SoapUI as "HTTP/1.1 413 FULL head" Response.

This is an old topic over years and was possible to bypass with a special property in .vmoptions but later-on it was not working and never fixed again.

According of change log, the overwrite of Jetty connector properties was introduced with SoapUI 3.5 Beta2 fixes:

2010-03-01 : 3.5 - the Protocol Release

SoapUI 3.5 adds support for JMS, JDBC and AMF for both functional and load-testing
[.....]

Library Updates
 •Jetty 6.1.22
[.....]
Beta2 fixes: [.....] - Added possibility to override Jetty Connector properties via soapui.mock.connector.XX system properties


But e.g. in SoapUI 4.6.2 is was not longer working, maybe it was due to update to Jetty 6.1.26?

BTW: Why is SoapUI using such old and unsupported Jetty Version, while the newest and stable is 9.x ?

 

My local hard coded fix was to get the Jetty 6.1.26 source code and to patch for my own the jetty-6.1.26.jar package to get a larger buffer.

AbstractBuffers.java

    private int _headerBufferSize = <my new value>;

 

Please provide a fix based on some .vmoptions Java properties -Dsoapui.mock.connector.headerBufferSize=<my new value>

And almost fundamental please provide a knowledge data base, where such atypical settings are described.

4 REPLIES 4
AJaensson
Staff

Hi,

 

This has been fixed in the maintenance builds of Ready! API (available here). Using that build, the -Dsoapui.mock.connector.headerBufferSize=<my new value> option is available again.

 

We do have plans to upgrade jetty, but it is a pretty big change and it has to be prioritized against other tasks.

 

Regards,

Anders

Ready! API developer

psy
Occasional Contributor

Hello,

thank you for the fix. I have downloaded the 1.4.1 Snapshot from 25.09. and the property is working again

-Dsoapui.mock.connector.headerBufferSize=<my new value>

I will see when it becomes  public in next 1.4.2 or 1.5 release and with an entry in release note.

psy
Occasional Contributor

Ready! API nightly build 1.4.1 contained the fix and now the version 1.5.0 is released, but no (sub) release note is mentioning this fix. http://readyapi.smartbear.com/about/release_notes/start As an improvement, it would be helpful to see all changes in release note. We have already enough fixes and features as submarine in our business applications. A tool for testing should be better. 😉
psy
Occasional Contributor

Version 1.6 is out, but the fix is never mentioned up to now in any change log. But the page for "Java Virtual Machine Parameters" contains the property. Issue is solved at all 🙂 http://readyapi.smartbear.com/soapui/working/environment_settings/jvm_options
cancel
Showing results for 
Search instead for 
Did you mean: