Ask a Question

soapUI NG and Maven

New Contributor

soapUI NG and Maven

Hi, I upgraded the maven-plugin to ready-api 1.2.2 Version (from maven plugin 5.0.0)

I get a couple of warning with:

[WARNING] The POM for eviware:reports:jar:1.0 is missing, no dependency information available


[WARNING] System property 'soapui.home' is not set! Using this directory instead: .
[WARNING] No base packages specified - no classpath scanning will be done


Failed to create icon: java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.


Why does the new maven-plugin needs X??? Tests are running but this error isn't really nice...


How can I set soapui.home? or get the reports.jar? or get rid of the X11 message (Beside that's a minimal server, there is no X installed! )


Occasional Contributor



Did you find answers to your questions? I do set my soapui.home in my pom.xml, but it does not seem to register.



Hi, sorry for the late reply.

No I didn't find a solution for that. I'm using soapUI and maven from Jenkins - and it's just a couple of warnings, so I ignored them. Also tried newer version with the same result. I'm not really shure where to set soapui.home in the pom.xml

Showing results for 
Search instead for 
Did you mean: