Ask a Question

Writing output xml to folder working abnormally in load testing

New Contributor

Writing output xml to folder working abnormally in load testing

I have a test suite in Soap ui pro which captures xml responses and stores to my local drive quite succesfully when I run the test suite in soap ui module.

In load ui of Ready Api, when I run the same test suite, initially it captures the xml with the right response, but due to some unknown reason it overwrites the same file again with a ‘no response’ file.

The behaviour is best shown in the attached video. You can see towards the end of the video that the same file which had valid reaponse initially is being overwritten.
Note that the files which had size more than 1 kb turns back into a 1 kb file!

The suite uses a data source steps which is set to be shared between threads of load tests.Even toggling the setting not to share between the threads produces similar results.

Kindly help!

Thanks in advance.

Hi @newrej,


It will be very helpful if you provide us with your project so that we could see how your test is configured. I recommend that you open a support case and attach your project to it:


Customer Care Team

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Showing results for 
Search instead for 
Did you mean: