Ask a Question

Trial license can't be found after 2 days


Trial license can't be found after 2 days

Hi there,


we are investigating on a bunch of Rest API testing tools and ReadyApi so far is the most convincing. Unfortunately I cannot use my trial license since yesterday anymore. Out of a sudden ReadyApi told me that it couldn't find any license anymore. I assume the 14 day eval license is hosted by Smartbear and I get access to it by using the "Smartbear login" approach. 
Unfortunately that ends up in the following error shown in the webbrowser that opens up when I click on "connect"

Request Id: b2566ab3-f07a-482d-9c0a-8f5998f08000
Correlation Id: 4dfc5bbf-68dd-4586-bdfb-70c163e40dc2
Timestamp: 2022-03-10T06:16:54Z
Message: AADSTS50105: Your administrator has configured the application SmartBearID ('70396b86-402d-4a5b-ba7d-45a94c63c6c6') to block users unless they are specifically granted ('assigned') access to the application. The signed in user '' is blocked because they are not a direct member of a group with access, nor had access directly assigned by an administrator. Please contact your administrator to assign access to this application.



I contacted my IT support regarding this but at least on the quick run they couldn't figure out what causes this. Hence I'd like to ask you guys why this issue suddenly could occur. Could I use ReadyApi the first two days because it simply didn't check the license and once it did and figured out that there is no license it set some flag and since then requires the license to start?
Is there a possibility to get a trial license that I can host on my machine so I don't have to use the log in approach? 

Any other suggestions to solve this issue?

Thanks a lot!

Community Hero

Hey @LennSar,

How long since you originally installed ReadyAPI....has it been 14 days, cos i read your post like the trial only lasted 2 days???

Ok...heres the bit where im making a total guess. Smartbear recently changed their licensing approach for ReadyAPI. Originally you had 2 license types : floaters and per machine, per user fixed term using license key files.

Rather than use these license key files Smartbear are going with ID based licensing (replacing the per machine per user option....dunno about if floaters have changed).

So! I think whats happened is that ReadyAPI has decided your trial period has expired and its looking but doesnt recognise your ID.

Total guess on my part, but it seems logical. If you still have 12 days left, you might want to contact Smartbear and explain.....they might work some magic. However if you installed it 2 weeks ago and only tried using it 2 days ago, i think youll have used up your time.


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

Yes you are right, I installed ReadyApi 3 days ago and suddenly have the mentioned issue. I will have a call today with someone from Smartbear and hope she can work something out.  

Showing results for 
Search instead for 
Did you mean: