Ask a Question

The JVM could not be started - Soap UI

Pas
Not applicable

The JVM could not be started - Soap UI

Hello,
Last week I have downloaded the Soap UI 3.6.1. and it was working fine. Now it start giving me an error when I try to invoke the application. The error is: "The JVM could not be started. The maximum heap size (-XMx) might be too large or anti virus or firewall tool could block the execution. My colleague is not getting this error we are on the same network and PC configuration.
Thanks for your help in advance
Pas
8 REPLIES 8
ceaserme
New Contributor

Hey Pas,

I had the same issue today morning while starting from the exe file (I installed from windows installer) and also have a JVM configured on the machine.

Within soapUI-3.6.1.vmoptions file in "bin" directory, I reduced the xmx from 1200m (default) to 486m and that makes it to work. Try this - it might help.

In case, you are using bat file to start, there is a separate xmx setting within bat and you will need to make this xmx change in bat file.

Hope it helps.

cheers
BrianAB
Not applicable

ceaserme wrote:
Within soapUI-3.6.1.vmoptions file in "bin" directory, I reduced the xmx from 1200m (default) to 486m and that makes it to work. Try this - it might help.


I had the same problem as the OP and your solution fixed it for me. Thanks for posting it.
khawaldar
New Contributor

I changed the value of xmx to 486 from 1024 in the bat file . But still getting the same error.
tzenzachary
Not applicable

I have the same problem, too, but I'm using PyCharm.
Will the same method work with pycharm?
I looked in the bin file but I don't know how to set the heap size to a smaller value.
What should I do now?
madden1942
Occasional Contributor

I just did this and it worked a treat! Thank you very much!!!
glindholm
New Contributor

Note - This is still a problem with SoapUI 4.6.4 and Windows 7.

I had to modify SoapUI-4.6.4.vmoptions in C:\Program Files (x86)\SmartBear\SoapUI-4.6.4\bin and change -Xmx1000m to -Xmx640m which is more difficult then it should be since Windows protects everything under C:\Program Files (x86) from user changes.

You have to first change the security settings on the file SoapUI-4.6.4.vmoptions and grant yourself write permission.

With recent versions of Windows, user changeable config files should be placed under C:\ProgramData\ not C:\Program Files (x86) .

Other that this, I've found SoapUI pretty useful so far (1 day of working with it).
hnoor0044
New Contributor

The JVM could not be started. The maximum heap size (-XMx) might be too large or anti virus or firewall tool could block the execution.

NOOR

Can you post the heap sizes assigned? Usually it should be fine if you assign 512m/1024m for min and max heaps. But not too large, as shown in the error.


Regards,
Rao.
cancel
Showing results for 
Search instead for 
Did you mean: