Ask a Question

SoapUi Pro get freeze under Test suite running

Occasional Contributor

SoapUi Pro get freeze under Test suite running

Hello SoapUi Pro users!


I have a problem, when I run a Test suite which contains 3 Test Case:

 - Ping Test Case

 - GetCodeTables Test case

 - Calculate2020 TestCase


I have 4.431 pieces of calculation, several times when the Test suite runs, the Soapui get freeze and the program can not answer.

My PC parameters are:


OS version:
Windows 10 Enterprise 64-bit 10.0.15063 build 15063


Hardware spec:
Intel® Core™ i5-6200U CPU @ 2.30GHz, 2400 Mhz
8 Gb RAM


I think it must be appropriate! I attached my actual toolrunner.bat and soapui-pro.bat files.


Has anyone had a similar problem? What could be the solution?





Community Hero

Hey @PG,

You say you have 4000 "pieces of calculation" and i dont know what that means from the context of what youre doing, but it sounds a lot.

Youre running ReadyAPI! on an 8Gig RAM, I5 and 8 used to have q lot of trouble running my tests on an I5 until i bought an I7 about 4 years ago. Im not saying you cant run ReadyAPI! on an I5, but it depends on the contents of your project file.

Have you launched windows taskmanager to check RAM and processor usage when trying to run your tests? It sounds like your resource profile is hitting your hardwares capacity.

Theres a vmoptions file that allows you to tailor your java heap size etc., but it doesnt work magic, bit that might help a little.

There is a Delay step you might add to your tests to slow them down, diminishing the amout of resource needed at any particular time, not a great reason to add a weight in...server latency yes, but client latency?

Anyway....thats all you got im afraid...maybe kill everything elsr running on your laptoo before you try executing your tests.

Its either try the above or change machines!


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Occasional Contributor

Hello @richie 


First of all I attached a simple request that I ran in the Calcuate2020 Test Case.

I have 6 Test Steps under this test case:

 - DataSource (with DB connection)

 - Caclulate2020 SOAP request

 - Property Transfer

 - DataGen

 - DataSink (with DB connection also)

 - DataSource Loop


I have another PC where I tried to run the Test Suite:

 - Processzor Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz, 3408 Mhz

 - Memory 16 GB RAM


But the result was the same 😞

I have no ReadyAPI, I only use the SoapUi Pro 5.1.1 software. I was watching the task manager change during the run, when the process was frozen, the processor was running at 100 % on both PC.


Where can I find the vmoptions file and what can I change?


Thank You!





SmartBear Alumni (Retired)

Thank you for help richie. 


Hi @PG , I see you are using an old version of the SoapUI Pro tool. Please consider installing ReadyAPI 3.0 and see how it works for you – this might be the solution you are looking for.  


The Pro license you have should let you use the SoapUI Pro functionality within ReadyAPI to the full extend. 

Here are some help articles you might find useful: migration from SoapUI to ReadyAPI and using SoupUI licenses

Let us know your progress! 

Sonya Mihaljova
Community and Education Specialist

Showing results for 
Search instead for 
Did you mean: