Ask a Question

SoapUI tests are failing

New Contributor

SoapUI tests are failing


We have been running some of our API Functional Tests for a while using soapUI & ReadyAPI.

Suddenly our tests are failing by saying  <h1>You must log in to access this URL.</h1> 

our application URL or credentials didn't change, same tests are working fine when I use postman.

Some how soapUI not able to connect to the application.


Not sure why / where is having problem, appreciate your help




Community Hero

Hey @lboggala,

Are you saying all your ReadyAPI! tests are now failing?
And they used to pass before?
Obviously something changed in your environment....have you identified what changed?

The response youre getting sounds like an authentication/authorisation issue. Whats the HTTP response code youre it a 401?

When i have issues where a request works in Postman but doesnt in ReadyAPI! or SoapUI, I use Fiddler.

Fiddler is an analysis tool that allows you to check the requests and compare them against each other. Essentially you setup Fiddler and proxy the requests to capture the details.

So submit your Postman request across Fiddler to your endpoint to capture the request, then do the same with ReadyAPI!


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
SmartBear Alumni (Retired)

Thanks for the great advice Richie!


@lboggala does this help?

Sonya Mihaljova
Community and Education Specialist

thanks Rich for you suggestion, will give it a try and we are also investigating if there were any changes with our environments.


Showing results for 
Search instead for 
Did you mean: