Ask a Question

Send HTTP request without appending the end point

Occasional Contributor

Send HTTP request without appending the end point

This question was asked in a previous thread but their answer is not my issue and no other answer was posited.

I have a HTTP request I would like to add to a load test. It is like this

When i run this in SoapUI i get an incomplete response. If I simply load this into a browser it works just fine.

It looks like SoapUI is actually sending HTTP/1.1

Is there a way to submit the request without appending it with HTTP/1.1?

Occasional Contributor

I saw the same on Mailinators' docs as well and I have no idea why it needs to work the way is does. 

I did find a horrible, ugly solution to my problem, shown in the screenshot.

I added the HTTP/1.1 to the domain value and the entirety of the messege came across.

The scary part. The final URL

...domain=true%20HTTP%2F1.1 HTTP/1.1

I have no idea why this would even be accepted as a valid request.

Hey @Lightem

Wow! Well, you got it working, but God that's ugly.

I'd still be tempted to raise a service request with them.....cos the api doesn't work as specced out in mailinator's requirements....and they need to know that....although i seriously doubt they don't know about it tbh.

Sorry i couldn't straighten it out for you, but at least you've found a workaround,

Nice one,

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Showing results for 
Search instead for 
Did you mean: