Ask a Question

Script1.groovy: 3: unable to resolve class @ line 3, column 1

New Contributor

Script1.groovy: 3: unable to resolve class @ line 3, column 1

I am using the SoapUI 5.2.1 to run a FTP related test case. The following script worked fine in my window 7, the it failed if I ran it on windows 8.1 Pro. Not sure why?


//import*    (tried this, but still see the error for FTPClient)

new FTPClient().with {
connect "" replyString
login "anonymous","" replyString
files = listFiles(".")

for (myfiles in files) {
if(myfiles.getName() =~ "trouble_report.tgz") {
context.mTime = getModificationTime(myfiles.getName()) "Found file, modified : " + context.mTime;

return context.mTime



Below is the output error messages:

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: Script3.groovy: 2: unable to resolve class
@ line 2, column 1. import; ^ org.codehaus.groovy.syntax.SyntaxException: unable to resolve class
p.FTP @ line 2, column 1. at org.codehaus.groovy.ast.ClassCodeVisitorSupport.addError( at org.codehaus.groovy.control.Res
olveVisitor.visitClass( at org.codehaus.groovy.control.ResolveVisitor.startResolving( at org.codehaus.gro
ovy.control.CompilationUnit$ at org.codehaus.groovy.control.CompilationUnit.applyToSourceUnits(
at org.codehaus.groovy.control.CompilationUnit.doPhaseOperation( at org.codehaus.groovy.control.CompilationUnit.compile(Compilati at groovy.lang.GroovyClassLoader.doParseClass( at groovy.lang.GroovyClassLoader.parseClass(GroovyClassLoader.j
ava:258) at groovy.lang.GroovyShell.parseClass( at groovy.lang.GroovyShell.parse( at groovy.lang.GroovyShell.par
se( at groovy.lang.GroovyShell.parse( at
mpile( at at at com.eviware.soapui.impl.wsdl.panels.teststeps.Gr
oovyScriptStepDesktopPanel$RunAction$ at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at
java.util.concurrent.ThreadPoolExecutor$ Source) at Source) Script3.groovy: 3: unable to resolve class org. @ line 3, column 1. import



What maybe wrong?


Thank you,



Super Contributor

From your error message it looks like you are using the Apache commons Net library:


My guess is that you have two installs of SoapUI, one has the libraies installed, the other doesn't, you can download the libraries from the above link, and then put them in your bin/ext directory. See the following page for details:

SmartBear Alumni (Retired)

Hi everyone,


@Radford, many thanks for your assistance!


@szheng, have you had a chance to try the suggestion that Radford provided? Does it help you accomplish your task?

We are looking forward to your reply.



Olga Terentieva
SmartBear Assistant Community Manager

New Contributor

Thank you for Radford great advice! By adding the missing file "commons-net-x.jar​" under the SoapUI folder \jre\lib\ext, re-ran the test case, the error is gone!

Showing results for 
Search instead for 
Did you mean: