Ask a Question

[Schema Compliance] Missing operation [XXX] in wsdl definition

Scarlet
New Contributor

[Schema Compliance] Missing operation [XXX] in wsdl definition

Hi there,

 

We have quite some functional tests running daily, that fail the schema compliance test with the error 'Missing operation [name-of-operation-here] in wsdl definition. Some test steps always fail on this step.

 

When running the tests manually the test step pass, the entire test case frankly. The test step in question also check for soap faults as well as certain values in the responses and they always pass. I have refreshed the WSDL files and I can see the operations there.

 

We are running Ready Api 3.6.0, what could be the issue?

 

Thanks,

Scarlet

5 REPLIES 5
nmrao
Community Hero

Ensure that the tool has the updated wsdl definitions and see if that helps!


Regards,
Rao.
sonya_m
SmartBear Alumni (Retired)

Thank you Rao!

@Scarlet please let us know if this helps! 


Sonya Mihaljova
Community and Education Specialist

Scarlet
New Contributor

Thank you Rao and Sonya, but unfortunately it did not help.

 

I got the latest WSLD files and updated them in the project, but I have the same results. Running the test manually it passes, but when running scheduled it/they fail/s.

nmrao
Community Hero

That's total weird.
Would try running the project using testrunner and see?


Regards,
Rao.
TommyTester
Occasional Contributor

Did you ever find a fix to this? I'm encountering the same issue in ReadyAPI 3.20.0. It only happens for two operations on a wsdl, the others are fine. As far as I can tell, the two operations in question look exactly the same as the working operations - apart from the obvious differences between the operations themselves.

cancel
Showing results for 
Search instead for 
Did you mean: