Ask a Question

Runing a composite ReadyAPI project from Github Actions

Occasional Contributor

Runing a composite ReadyAPI project from Github Actions

Hi All, @nmrao 


Am trying to execute a test suite from ReadyAPI project in GitHub via GitHub Actions on a self-hosted runner.

As per the documentation available on ReadyAPI, I wrote the following workflow file in GitHub. But while running the workflow from Github am getting the error "No project file is specified." To upload the project to GitHub the ReadyAPI project is converted to composite project and the composite project don't have the readyapi project.xml file.

Any suggestions on how to write the command line in the workflow file to run the ReadyAPi tests from Github Actions

PFB the workflow file am using now (which is giving the error "No project file is specified.)




Regular Contributor

Are you generating the command line from ReadyAPI, like [here]? You may need to specify the full path to TestRunner.

[[ kITt: keep IT testing ]]
Champion Level 3

The error seems to be correct as there is no project file specified to be executed.

So, please provide the project path as well (hope that is available under github repo) at the last in the command.

Please find the documentation for reference:

Occasional Contributor

Hi @Kitt , @nmrao ,


When the project is configured to github the project is changed to composite project as shown below and dont have any <projectname>.xml file ( As shown below)


Project file before configuring GItHub

projectfile_before push to Github.PNG


When GitHub is configured in ReadyAPI for the project

ProjectFile_Composite Project convertion.PNG


Composite project.PNG


When I tried to generate the Command line from the TestRunner GUI from ReadyAPI, only the destination of the composite project is shown as the Default Environment argument


Am able to run that command in the command prompt in my local machine and the tests are running without any errors. The mentioned error " No Project file specified" is displaying only when I try to run the tests from Github Actions with the same command line generated from TestRunner GUI.

Occasional Contributor

Hi, This I have solved with some changes in the workflow file.

Modified the run command as 


run: |
C:\Users\username\AppData\Local\SmartBear\ReadyAPI-3.41.0\bin\testrunner.bat "-sTest Suite 1" -r -a -j "-fD:\ReadyAPI Reports" "-RJUnit-Style HTML Report" -FXML "-ETest" D:\DSP

Showing results for 
Search instead for 
Did you mean: