Ask a Question

ReadyAPI not displaying List of Functional Tests Overview

Rememo
Occasional Contributor

ReadyAPI not displaying List of Functional Tests Overview

Hi,

 

When using ReadyAPI, the Functional Tests list overview is not displaying and not the showing any Test Suites?  Does anyone know how to fix this issue?

 

Thanks

5 REPLIES 5
richie
Community Hero

Re: ReadyAPI not displaying List of Functional Tests Overview

Hey @Rememo 

 

 

I don't think anything is broken - I just think you need to alter your 'view'.  Couple of questions:

 

Q1. What version of ReadyAPI! are you using?

 

Q2. Can you provide screenshots of your ReadyAPI instance so we can see exactly what you're looking at and what you're attempting to view please?

 

Is your 'focus' on the 'Dashboards', rather than 'Projects'?  The reason I ask - when you launch ReadyAPI - the default focus is displaying the 'Dashboards' and you cant see any projects/apis/testsuites/etc. (see below)

Capture.PNG

 

 

If you click on the 'Projects' button (adjacent to the 'Dashboards' button)  - the 'project navigator' is revealed and it's here in the 'project navigator' where you see all your projects, their services/APIs and the associated testsuites/testcases - see the following screencapture.

 

Capture.PNG

 

 

Cheers,

 

Rich

 

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Rememo
Occasional Contributor

Re: ReadyAPI not displaying List of Functional Tests Overview

I am using ReadyAPI v3.7.0.  

 

It is not the 'view' as I can see all projects clearly.  

 

Example below of PetStore:

Rememo_0-1633601751203.png

 

Example below still stays on PetStore when I click Functional Tests within my project:

Rememo_1-1633601942558.png

When I go to click Functional Tests in my project it doesn't seem to 'update' and show my Functional Tests and keeps staying on 'last clicked item'.

 

I have tried removing and importing again etc.

 

Thanks

richie
Community Hero

Re: ReadyAPI not displaying List of Functional Tests Overview

Hey @Rememo 

 

Ok - I've tried replicating what I can see on your 2nd screencapture. 

 

You have added in the petstore swagger to create the petstore project

 

You have a single testsuite in the 'Functional Tests' object.

 

You have the pestore APIs object minimised

 

You have the 'Functional Tests' object expanded to one level (revealing a single testsuite)

 

See below for my attempt to replicate your screenshot

 

At this point, I've clicked on the 'Functional Tests' object and it alters the content in the right hand frame as follows:

Capture1.PNG

 

 

 

If I click on the 'testsuite' object in my hierarchy (entitled 'TestSuite 1') - the following changes occur (the right hand side changes from viewing the TestSuite to TestCase level):

Capture2.PNG

 

 

 

 

If I click on the 'testcase' object in my hierarchy (entitled 'TestCase 1') - the following changes occur (the right hand side changes from viewing the TestCase to TestStep):

 

Capture3.PNG

 

 

Can you try and replicate what I've done above so we can identify if you are doing something different to me?

 

 

You mentioned "When I go to click Functional Tests in my project it doesn't seem to 'update' and show my Functional Tests and keeps staying on 'last clicked item'."  HOWEVER -  I think what you're describing is actually the correct behaviour - or I'm misunderstanding your issue.  If you click on 'Functional Tests', the object will expand once only revealing it's child record which is >=1 TestSuite object.  If you click on the 'Functional Tests' object at this point after already expanding the 'tree' to reveal the TestSuite object -nothing will happen.  The 'Functional Tests' object can only be expanded once to reveal it's child/children records.  You cannot click on the 'Functional Tests' object multiple times to expand all it's children's children.  Clicking on the 'Functional Tests' object will ONLY ever expand it's first level children.  What I mean is, clicking on the 'Functional Tests' object will NEVER expand it's grand children (testcase level) or great grand children (teststep level)

 

 

Does that clear things up?

 

If it doesnt, please respond back,

 

Cheers,

 

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Rememo
Occasional Contributor

Re: ReadyAPI not displaying List of Functional Tests Overview

You've completely misunderstood and it's not the correct behavior as you are using the same Project and showing a hierarchy which is irrelevant to my problem.  The screenshots show I am using a different project (example FloorStore), whereas PetStore was just an example of how it should display for Functional Tests listing out all the Test Suite on the right hand side, but the display for 'FloorStore' Functional Tests within my Project keeps referencing the 'last item clicked' therefore it will not display the Test Suite list.

 

It must have become corrupt.  I have created a new project and brought all API's and can successfully see the list of Test Suites within my Functional Tests.

 

If anyone else has experience something similar and been able to resolve it let me know.

richie
Community Hero

Re: ReadyAPI not displaying List of Functional Tests Overview

Hey @Rememo 

 

I apologise if I misunderstood.  From each of your screencaptures - the Petstore project was the only one highlighted/selected.

 

Cheers,

 

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
cancel
Showing results for 
Search instead for 
Did you mean: